This is a split board - You can return to the Split List for other boards.

I would just like to say that Origin is really as bad as everyone says

#1HighOnPhazonPosted 9/11/2013 9:59:32 PM
It's a terrible program and If I could kill it, I would kill it with fire, then I'd pee on the ashes, then light the pee soaked ashes on fire again.

I'd go into detail why I'm pissed about this crap ass program right now but I don't want to waste too much time, but I'm sure people will come to their own conclusions. Everything good about Steam is not here, everything bad about Steam (which is very little) is tripled here.
---
GT/Steam: AncientToaster
i5 3750K / ASRock Z77 Extreme 4 / Patriot Viper 8GB /Gigabyte GTX 660 OC 2GB / Corsair TX650
#2steveboblarryPosted 9/11/2013 10:01:02 PM
2/10
---
Chief Keef makes music for people who spin around in circles to get dizzy
#32Dhas_a_MIGRANEPosted 9/11/2013 10:02:21 PM
Urine isn't flammable, too much water. You'd have to let it dry out first before lighting it on fire again.
---
Pearl Code: 0731 1228 8254 White Code: 0862 2790 1982
SSBB: 0989-1461-9542
#4DerPancakePosted 9/11/2013 10:02:44 PM
It opens faster than Steam, it opens game faster than Steam.

Its better than Steam, all it needs is the games.
---
Nope Nope Nope!!!!
#5LoshadtPosted 9/11/2013 10:04:06 PM
I didn't have a problem with Origin until I read the ToS. Now I'm glad the only origin game I have is Bad Company 2. A game I got for free thanks to that coupon rush a while ago, and one that doesn't need Origin installed to play.

So basically, the only game I bought from EA in a decade was free.
---
Russian is my first language, so yes there may be a spelling error or two.
Kirino is best girl.
#6HighOnPhazon(Topic Creator)Posted 9/11/2013 10:05:06 PM
Steam opens nearly instantly for me.

Games start up nearly instantly in Steam.

I click on Mass Effect 2 on Origin, it says "Syncing Cloud Data" then it syncs, then the game doesn't load. I hit Play, it does the same thing again, and never loads.
---
GT/Steam: AncientToaster
i5 3750K / ASRock Z77 Extreme 4 / Patriot Viper 8GB /Gigabyte GTX 660 OC 2GB / Corsair TX650
#7DerPancakePosted 9/11/2013 10:07:23 PM
HighOnPhazon posted...
Steam opens nearly instantly for me.

Games start up nearly instantly in Steam.

I click on Mass Effect 2 on Origin, it says "Syncing Cloud Data" then it syncs, then the game doesn't load. I hit Play, it does the same thing again, and never loads.


Open Origin as administrator, and you can deactive Cloud data.
---
Nope Nope Nope!!!!
#8matu90rkPosted 9/11/2013 10:12:03 PM
DerPancake posted...
It opens faster than Steam, it opens game faster than Steam.

Its better than Steam, all it needs is the games.


It's the pro-Linux argument all over again. I don't care how much better it runs if I can't use it to run the things I want.
#9HighOnPhazon(Topic Creator)Posted 9/11/2013 10:19:24 PM
Yeah that doesn't work.

I hit play, nothing happens.

I'm going to try this next:


Sentinel
alexmf138
Posts: 4
Registered: ‎01-20-2013
Re: Mass Effect 2 Won't Launch
Options

‎01-29-2013 07:18 AM

Hello Everyone, I managed to fix my problem..



First, the background.



I downloaded the trilogy from Origin, cleared ME1, then opened ME2, everything went well till I realized I hadn't picked my save file...so I went out the game, used the ME2 config file and screwed up my game as everyone else did. Then I tried downloading and installing the game, and it didnt work. I tried to add my savefile manually and it didnt work either. So



What I did:





1- Deleted "MassEffect2Config.exe" from C:\Program Files\Origin Games\Mass Effect 2\Binaries.

2- Deleted the save file from ME1 from C:\Users\(USERNAME)\Documents\BioWare\Mass Effect 2\Save\ME1

3- Run "Repair Installation" for ME2 in origin.

4- After it finished, I added my save file manually to the ME2 folder in "C:\Users\(USERNAME)\Documents\BioWare\Mass Effect 2\Save\ME1"



Opened the game, and worked fine.



Hope it helps.

---
GT/Steam: AncientToaster
i5 3750K / ASRock Z77 Extreme 4 / Patriot Viper 8GB /Gigabyte GTX 660 OC 2GB / Corsair TX650
#10HighOnPhazon(Topic Creator)Posted 9/11/2013 10:25:26 PM
That didn't seem to work either.

Lovely
---
GT/Steam: AncientToaster
i5 3750K / ASRock Z77 Extreme 4 / Patriot Viper 8GB /Gigabyte GTX 660 OC 2GB / Corsair TX650