This is a split board - You can return to the Split List for other boards.

need serious help here!!! comp shut down outta nowhere!

#1LiQuiDsWorDs56Posted 9/12/2013 7:55:38 AM
I had turned my computer on when I got home from work and when I got out of the shower, my tower was off. The power button on my mobo is lit but doesnt do a thing when I press it. Psu bad or something else die?
---
i7-930@3.5GHz l Asus P6X58D-E l EVGA SC Titan l 12gb Dominator l AX850 PSU l H100i l 6Tb 7,200 rpm l 256gb Samsung Pro I BD Drive l 900D I Alienware Optx
#2Cool_Dude667Posted 9/12/2013 8:17:21 AM
Unplug all nonessiential hardware, test RAM sticks,reseat all powerconnectors, if you still cant boot into the bios try clearing the cmos. do ur cpu fans spin when u try booting?
---
Not changing this sig until Christ returns -- Started 30 A.D
3770K @ 4.2Ghz | 16GB Corsair Vengeance | GTX 670 SLi
#3LiQuiDsWorDs56(Topic Creator)Posted 9/12/2013 8:32:19 AM
I reseated the ram, unplugged all devices except the monitor and still nothing.
---
i7-930@3.5GHz l Asus P6X58D-E l EVGA SC Titan l 12gb Dominator l AX850 PSU l H100i l 6Tb 7,200 rpm l 256gb Samsung Pro I BD Drive l 900D I Alienware Optx
#4NingishzidaPosted 9/12/2013 8:40:39 AM
maybe ask a friend to bring you over their PSU
#5NingishzidaPosted 9/12/2013 8:41:51 AM
smell the vent of the PSU, maybe a capacitor blew if you detect burning
#6LiQuiDsWorDs56(Topic Creator)Posted 9/12/2013 8:43:37 AM
The PSU doesnt smell burnt and no fan whatsoever spin when pressing power. Should I go out and buy a psu tester?
---
i7-930@3.5GHz l Asus P6X58D-E l EVGA SC Titan l 12gb Dominator l AX850 PSU l H100i l 6Tb 7,200 rpm l 256gb Samsung Pro I BD Drive l 900D I Alienware Optx
#7LiQuiDsWorDs56(Topic Creator)Posted 9/12/2013 8:44:00 AM
The PSU doesnt smell burnt and no fan whatsoever spin when pressing power. Should I go out and buy a psu tester?
---
i7-930@3.5GHz l Asus P6X58D-E l EVGA SC Titan l 12gb Dominator l AX850 PSU l H100i l 6Tb 7,200 rpm l 256gb Samsung Pro I BD Drive l 900D I Alienware Optx
#8SnadadosPosted 9/12/2013 8:49:21 AM
While the PSU is plugged in, use a paper clip to bridge the green and a black wire on the PSU's 24 pin motherboard connector and then flip the power switch.
Cheapest PSU test around.
---
Have you accepted Raspberyl as your loli and savior?
#9StormKMDPosted 9/12/2013 9:04:03 AM
Snadados posted...
While the PSU is plugged in, use a paper clip to bridge the green and a black wire on the PSU's 24 pin motherboard connector and then flip the power switch.
Cheapest PSU test around.


Here's a better guide:

http://www.overclock.net/t/96712/how-to-jump-start-a-power-supply-psu-test-a-power-supply-and-components
---
MSI 660 GeForce 2GB | i5 3570K | AsRock Z77 Pro3 | Seagate Barracuda 500GB | Ballistix 8GB | Corsair CX430
#10LiQuiDsWorDs56(Topic Creator)Posted 9/12/2013 10:03:41 AM
Just bought a tester and tried it with the 24 pin first and it was beeping while the the +12V2 icon was flashing "LL"
---
i7-930@3.5GHz l Asus P6X58D-E l EVGA SC Titan l 12gb Dominator l AX850 PSU l H100i l 6Tb 7,200 rpm l 256gb Samsung Pro I BD Drive l 900D I Alienware Optx