This is a split board - You can return to the Split List for other boards.

"FireFox is already running" error in Linux

#1ElDudorinoPosted 10/6/2013 4:57:13 PM
Is anyone familiar with this problem, and is there a rhyme or reason for when and why it happens? My father-in-law is extremely computer illiterate and had a Vista machine full of viruses so I was going to reformat when I had the bright idea to just install Ubuntu so he wouldn't have to worry about viruses. After all, if he's only running FireFox and nothing else, he shouldn't have to know his way around Linux.

But now, rebooting will randomly make it so that FireFox will not load due to the infamous error : "FireFox is already running." I'm looking into creating a shortcut to kill the FireFox task easily since it will work after that, but it would be nice if FireFox just worked! Also, the folder with the profiles.ini file doesn't have any lock files that I saw.

Does anyone know a good way to completely avoid having this error occur? It's in Ubuntu 12.4 (since I happened to have a bootable disc on-hand for troubleshooting).
#2ElDudorino(Topic Creator)Posted 10/6/2013 4:59:50 PM
Completely fresh install, by the way. Haven't updated anything.
#3Darkcloud20Posted 10/6/2013 5:05:58 PM
the process is still running you have to kill it. If it is in zombie state you pretty much have to restart.
---
http://raptr.com/Darkcloud1987
#4Digital StormPosted 10/6/2013 5:08:47 PM
http://www.mattcutts.com/blog/how-to-fix-firefox-is-already-running-error/
---
Ooo eee, oo ah ah, ting tang, walla walla bing bang.
#5Rexdragon125Posted 10/6/2013 5:42:30 PM
It does this in Windows, too. Try a different browser.
#6ElDudorino(Topic Creator)Posted 10/7/2013 7:32:42 AM
Thanks for the suggestions. I did not find any trace of the lock files last night (view hidden files was on), though the profiles.ini was there as expected in the .mozilla/firefox folder and I erased that (and had to re-instate all of the bookmarks and everything he had). Still happens. Killing the task would work for that session but there's no way I'd be able to explain to my father-in-law (whose English is marginal at best to begin with) how to close the task. I was looking into creating a terminal shortcut to kill the program but the PID changes every time it loads up and I didn't know how to make like a batch file to find the process number and then output the result into a kill command. I've never been that Linux-oriented so it probably would have taken me a while to sort that one out and I unfortunately wasn't able to spend long with the computer last night. I was starting to feel bad so I explained to him that he can still log into Windows (since it's a dual-boot) but told him not to do any online banking from Windows since that install is mad virusy.

The real solution probably IS to discard FireFox in favor of Chrome or something; I was avoiding it since I don't like Chrome personally and I know I'd have to mess with it to get it looking how FireFox did. I would honestly probably change the icon back to the FireFox one just so as not to confuse the poor guy.

Oh well. I was hoping there was an easily-pinpointable cause as to why FireFox would do this since obviously it doesn't happen on the majority of computers but it does cause a lot of people grief. It even works perfectly from Windows but not from Linux on the same machine, even though I've seen reports that it happens in Windows as well. So puzzling!
#7SinisterSlayPosted 10/7/2013 7:36:18 AM
Isn't there an option to allow multiple instances of firefox?

Try turning that on, then ignore the stale processes. They will go away when he restarts his computer.
---
He who stumbles around in darkness with a stick is blind. But he who... sticks out in darkness... is... fluorescent! - Brother Silence
#8ElDudorino(Topic Creator)Posted 10/7/2013 7:46:11 AM
SinisterSlay posted...
Isn't there an option to allow multiple instances of firefox?

Try turning that on, then ignore the stale processes. They will go away when he restarts his computer.


That's a really good approach. I think I'd have to create a second shortcut, though, because my understanding is I'd need to have one shortcut loading FireFox as normal then a second running it as firefox -no-remote -P secondprofilename . Probably not the end of the world, though I guess installing Chrome might be the better option if I can get everything looking how it should. I'll install Linux on my laptop so I can mess with it from home and see how it all works.

Thanks!
#9SinisterSlayPosted 10/7/2013 7:50:40 AM
ElDudorino posted...
SinisterSlay posted...
Isn't there an option to allow multiple instances of firefox?

Try turning that on, then ignore the stale processes. They will go away when he restarts his computer.


That's a really good approach. I think I'd have to create a second shortcut, though, because my understanding is I'd need to have one shortcut loading FireFox as normal then a second running it as firefox -no-remote -P secondprofilename . Probably not the end of the world, though I guess installing Chrome might be the better option if I can get everything looking how it should. I'll install Linux on my laptop so I can mess with it from home and see how it all works.

Thanks!


This is what I find, doesn't seem to need another profile.

@echo off
set MOZ_NO_REMOTE=1
start "" "C:\Program Files\Mozilla Firefox\firefox.exe" -p
set MOZ_NO_REMOTE=0

---
He who stumbles around in darkness with a stick is blind. But he who... sticks out in darkness... is... fluorescent! - Brother Silence