This is a split board - You can return to the Split List for other boards.

I'm averaging about 30FPS in Battlefield 4. What gives?

#1Tony_Biggie_PunPosted 10/8/2013 9:09:11 AM
Even on all low settings at 1080p I average around 30fps. Going from Ultra to Low doesn't do much for performance.

Is there anyway to get the game to run at 60fps on my system? Battlefield 3 ran at 60fps with a couple dips to 45-50 in multiplayer. Battlefied 4 dips to 20fps and even lower in really hectic areas.


I have an i7 920(stock clocks cant overclock due to motherboard) and a Radeon HD 7950 Boost(Stock Clocks/I can overclock this if needed though)
---
http://i.imgur.com/Z3MIjNj.jpg
You can tell a lot about a person based on how they treat the weaker members of society.
#2snkboiPosted 10/8/2013 9:12:46 AM
this is why

i7 920(stock clocks cant overclock due to motherboard)
Radeon HD 7950 Boost

the game is being bottlenecked, you have a 1st gen i7 at stock clock
---
i think it's nice
#3NicodimusPosted 10/8/2013 9:18:01 AM
Everybody is getting lousy performance. It's the beta.
---
Intel i5 4670K | Corsair 16GB DDR3 | Gigabyte GTX 770 4GB | ASUS 27" 1440p
Corsair 480GB SSD | WD 4TB HDD | Fractal Design R4 | Corsair 750MX | Win7Ult 64
#4BIGGESTPS3FANPosted 10/8/2013 9:19:11 AM
I'm getting fine performance, even with an i5 with everything on ultra. It's definitely older CPUs that are really hurting.
---
Intel i5-3570k | Sapphire Vapor-X HD 7970 x2 | 8 GB G.Skill Ripjaw X | Asus P8Z77-V Pro | Corsair 500R | Corsair HX750 | 1 TB Seagate HDD | 120 GB Intel 520 SSD
#5Fade2black001Posted 10/8/2013 9:23:24 AM
Tony_Biggie_Pun posted...
Even on all low settings at 1080p I average around 30fps. Going from Ultra to Low doesn't do much for performance.

Is there anyway to get the game to run at 60fps on my system? Battlefield 3 ran at 60fps with a couple dips to 45-50 in multiplayer. Battlefied 4 dips to 20fps and even lower in really hectic areas.


I have an i7 920(stock clocks cant overclock due to motherboard) and a Radeon HD 7950 Boost(Stock Clocks/I can overclock this if needed though)


I have a 6950 and the default settings the give are all high and 2-3 things on ultra even and I average 30fps.
---
We're Americans! We don't quit just because we're wrong.
We just keep doing the wrong thing until it turns out right.
#6Benjamin_ButtonPosted 10/8/2013 9:25:11 AM
Im averaging 30fps low settings 1080p & 1080 60fps ultra on my AW
---
http://i.imgur.com/KNzJR.gif
Macbook Pro Retina i7-3840QM @ 2.8GHz | Nvidia 650m 1GB GDDR5 | 16GB DDR3L Ram | 750GB Flash Storage
#7Tony_Biggie_Pun(Topic Creator)Posted 10/8/2013 11:57:35 AM
Benjamin_Button posted...
Im averaging 30fps low settings 1080p & 1080 60fps ultra on my AW


whats your specs?
---
http://i.imgur.com/Z3MIjNj.jpg
You can tell a lot about a person based on how they treat the weaker members of society.
#8BuburibonPosted 10/8/2013 12:04:54 PM
BIGGESTPS3FAN posted...
I'm getting fine performance, even with an i5 with everything on ultra. It's definitely older CPUs that are really hurting.


Indeed. I decided to give it a go just to see how badly optimized it was, and to my surprise frame rates fluctuated between 70-120fps on ultra, with ~85fps average. Not bad at all since I'd cap it at 60fps anyway.

That's on Windows 8, by the way.
---
3770K @ 4.5Ghz | 16GB | TITAN
Steam | PSN | XBL: GVAmson23
#9_GRIM_FANDANGO_Posted 10/8/2013 12:07:11 PM
A lot of people are seeing abd performance. For now, I would not conclude this is due to your specs yet. Though just to be safe, I am upgrading my CPU and motherboard.
---
I5 760 | GTX 760 | FILCO Majestouch 2 tenkeyless | Zowie FK | Asus Xonar DGX | Sennheiser HD 518 | Samsung S24A350H
#10ThescyyPosted 10/8/2013 12:23:21 PM
Are you running windows 7 or 8? The beta runs like crap on Windows 7.

Nicodimus posted...
Everybody is getting lousy performance. It's the beta.


Not everyone.
---
i7 3930k @ 4.5Ghz | H220 | asrock x79 extreme 9 | 16GB 1600mhz ram | SLI GTX 780 | Samsung 830 256GB SSD | 8TB HDDs | EVGA Supernova 1300 G2 | Fractal design R4