This is a split board - You can return to the Split List for other boards.

Something is wrong with my games! Help!

#1joeman2004Posted 12/7/2013 7:58:06 AM
I just purchased a new laptop (http://www.amazon.com/Lenovo-IdeaPad-Y510p-Laptop-Computer/dp/B00EKK0Q6Y) and I seem to be having nothing but trouble so far. The major issue at hand is that my graphics card seems to be messing up...I think. I know the drivers are up to date cuz I check the Nvidia Geforce experience program and it said they were up to date. The problem is when I go to play my games I never know what I'm gonna get. Sometimes I can run them on ultra settings and they will play as smooth as silk and other times I'll boot up a game and it runs at about 2fps. I don't know what is causing this. I have even had a tech remote in and clean up the laptop from any apparent infections. So I know it's squeaky clean.

Has anyone else had experiences similar to this? And is there a simple fix? Thanks guys!
#2ATARIJAWAPosted 12/7/2013 8:06:08 AM
This is why SLI'ing 2 video cards (the weakest gaming level card available also) in a laptop is a bad idea.
---
Gamefaqs game rating system : 10 = Best Game Ever. 8-9. Crushing dissapointment. Below 8 :Total Garbage. This is getting ridiculous. people agreeing so far 105
#3wildog2006Posted 12/7/2013 8:34:15 AM
NVIDIA Dual SLI GT 750M


Is that saying it has 4 GPU's? Or, much more likely, Amazon is dumb.
---
Insert generic offensive/slightly racist/holier than thou/fanboy/douchebag/elitist comment here.
#4Davel23Posted 12/7/2013 9:57:32 AM
That's a pretty standard description, to differentiate it from tri- and quad-SLI.
---
Your mom's box.
#5Fayt349Posted 12/7/2013 10:05:01 AM
I used to have that laptop. It runs at like 2 FPS if it's not plugged in lol. Lenovo requires to be plugged in to play games.
---
Intel i5 3570k||Vengence 8 GIG DDR3 RAM||EVGA GTX 760 ||4 TB WD Black+1TB Seagate + 128 gig Samsung Pro SSD || Corsair 650W |Asus MOBO||CM scout advance 2 case
#6Rexdragon125Posted 12/7/2013 11:10:40 AM
joeman2004 posted...
I just purchased a new laptop

I found the problem
#7joeman6Posted 12/7/2013 4:10:06 PM
I see someone stole my user name.
---
PSN: pluto-3_ Xbox GT: NinjaPainis
http://backloggery.com/joeman6
#8AteasPosted 12/7/2013 4:20:10 PM
joeman6 posted...
I see someone stole my user name.


Except his account was created four years before yours.
#9joeman2004(Topic Creator)Posted 12/7/2013 9:41:20 PM
Fayt349 posted...
I used to have that laptop. It runs at like 2 FPS if it's not plugged in lol. Lenovo requires to be plugged in to play games.


Haha, yeah after 30 min online with a tech I discovered this. I felt stupid. At least it was a quick fix though.
#10joeman6Posted 12/8/2013 12:08:27 AM
Ateas posted...
joeman6 posted...
I see someone stole my user name.


Except his account was created four years before yours.


Hahaha did not see that.
---
PSN: pluto-3_ Xbox GT: NinjaPainis
http://backloggery.com/joeman6