This is a split board - You can return to the Split List for other boards.

Is something wrong with my R9 290?

  • Topic Archived
  1. Boards
  2. PC
  3. Is something wrong with my R9 290?
2 years ago#1
Hello, recently I got an Asus R9 290, also I have an i5 2500k at 4.0ghz and 8gb DDR3. Here's the "issue" though. I was hoping that I could keep a constant 60fps on BF4 at 1080p on ultra, but it seems I can't. On Paracel Storm, the framerate keeps jumping between 40-60fps depending on where I look. The real issue though, no matter what game I play, is that the gpu usage is never at constant 90-100%, it's always jumping around between low and high values, and I don't suppose this was supposed to happen. I obviously wouldn't mind some frames dropping here and there but it just feels weird.

http://imgur.com/5fo0rPP

I even tried setting +20% power limit and having the fan at 50% speed constant so it's not overheating. Also, everytime I play a game, the fan doesn't really seem to move around move. It usually stays around the 30%~ish fan speed, I can't even hear it really, which is why I manually set it this time.

Haven't got any BSOD's and nothing's overheating atall. Any thoughts?
---
Steam Profile: http://steamcommunity.com/id/xRuneXero
3DS FC: 1719-4162-7550 - Rune (PM me if you add me).
2 years ago#2
Sounds about right framerate wise, on ultra with full AA etc you'd need to be looking at dual gpu setups, secondly your GPU shoudln't be sitting at 100% all the time useage will fluctuate (although looking at the Afterburner screen cap it does look weirdish.)
Can you post more GPU useage logs in different scenarios?

Try and update drivers to latest beta version see what effect that has on fps.
2 years ago#3
What I think is happening is that you get to a part of the game where the FPS is limited by your CPU so there is no need for the GPU to work harder than to give you the limit that is created by your CPU, that is why it doesn't work at 100%. I've noticed this as well and this is just my hypothesis. Would someone shed some light on whether this is possible?
---
Xbox Live GT:ScaryPillow , iHaruyuki TERA:
LoL : ScaryPillow Maplestory: MLGLordly 16x I/L Arch Mage
2 years ago#4
I looked into this myself this morning and came across many people saying that the usage in msi afterburner isn't working right.
---
http://i.imgur.com/XqIF7rn.gif
2 years ago#5
You gpu should never be sitting at max, unless your doing a bench or something similar.
---
Ha! Made you read |TJ07| i5-3570k| Asus p8z77-v| GB GTX 770 4gb sli|16gb Corsair veng| 1TB WD HDx2| 128gb Samsung ssd| XSPC Raystorm RS360 kit|
2 years ago#6
kill2this posted...
Sounds about right framerate wise, on ultra with full AA etc you'd need to be looking at dual gpu setups, secondly your GPU shoudln't be sitting at 100% all the time useage will fluctuate (although looking at the Afterburner screen cap it does look weirdish.)
Can you post more GPU useage logs in different scenarios?

Try and update drivers to latest beta version see what effect that has on fps.


If that sounds like the right framerate for the R9 290 then I'm a bit more relieved I guess. I'll post some more logs tomorrow from different games as it's getting a bit late. I'll also look into more info about Afterburner not giving correct data.

Thanks everyone so far, I'll be back tomorrow
---
Steam Profile: http://steamcommunity.com/id/xRuneXero
3DS FC: 1719-4162-7550 - Rune (PM me if you add me).
2 years ago#7
Altmadragon posted...
You gpu should never be sitting at max, unless your doing a bench or something similar.


This is really false. I get 99 percent GPU usage in tons of games on my 570. ESPECIALLY BF3.
---
That which can be asserted without evidence, can be dismissed without evidence. - Christopher Hitchens
2 years ago#8
JMartinho posted...
kill2this posted...
Sounds about right framerate wise, on ultra with full AA etc you'd need to be looking at dual gpu setups, secondly your GPU shoudln't be sitting at 100% all the time useage will fluctuate (although looking at the Afterburner screen cap it does look weirdish.)
Can you post more GPU useage logs in different scenarios?

Try and update drivers to latest beta version see what effect that has on fps.


If that sounds like the right framerate for the R9 290 then I'm a bit more relieved I guess. I'll post some more logs tomorrow from different games as it's getting a bit late. I'll also look into more info about Afterburner not giving correct data.

Thanks everyone so far, I'll be back tomorrow


Your log doesn't look right at all man.

You should see a line of roughly 95-99% usage at all times in BF titles.
---
That which can be asserted without evidence, can be dismissed without evidence. - Christopher Hitchens
2 years ago#9
Shebeskii posted...
Altmadragon posted...
You gpu should never be sitting at max, unless your doing a bench or something similar.


This is really false. I get 99 percent GPU usage in tons of games on my 570. ESPECIALLY BF3.


Getting 99% is a huge difference from what I said "sitting @ 100"
---
Ha! Made you read |TJ07| i5-3570k| Asus p8z77-v| GB GTX 770 4gb sli|16gb Corsair veng| 1TB WD HDx2| 128gb Samsung ssd| XSPC Raystorm RS360 kit|
2 years ago#10
killkount posted...
I looked into this myself this morning and came across many people saying that the usage in msi afterburner isn't working right.


Not working right for the 200 series? It works fine for my 570.
---
That which can be asserted without evidence, can be dismissed without evidence. - Christopher Hitchens
  1. Boards
  2. PC
  3. Is something wrong with my R9 290?

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived