This is a split board - You can return to the Split List for other boards.

Display driver stopped working suddenly. No longer lets me play games.

#1Jason_Ryu_3Posted 12/28/2013 9:22:13 PM
Laptop: Sager NP8130

Geoforce GTX 560m
i7-2630qm @2.00 GHz
Driver version 331.82 (latest one)
Windows 7 64bit Home premium


I was playing Assassins Creed when the game switched out (like as if I alt+tabbed, but I was using a controller) and all I could see was the window border, but the game was still running (I could hear the audio). tried loading the game again, and it crashed.

Next thing I knew the screen was going crazy and I was getting constant "display driver has stopped responding and has recovered" messages. Tried getting the latest driver, installed it. Still no go. I still get that error message if I load ANY games, and occasionally at random times, but nowhere near as often. Any ideas?
---
http://i293.photobucket.com/albums/mm80/Jason_Ryu/MS%20Paint/Jason_Ryu.jpg
Soul Silver FC: 1979 0236 8128
#2castrejon04Posted 12/28/2013 9:26:21 PM
It happens with my graphics card from time to time on my desktop. It's probably because there is not enough resources to power up the card fully or something is consuming your computer's resources which can cause the card to stop responding.. It can't be because of the drivers since it happens on both chipsets.
---
"Don't let it end like this...Tell them I said something." Pancho Villa
#3killkountPosted 12/28/2013 9:29:50 PM
too hot is what im guessing. or overclocked too much. happened with my GTX 570 but I'd just lower the clocks and be good to go..same with my 8800GTX but that thing didn't like to overclock at all.
---
http://i.imgur.com/XqIF7rn.gif
#4Bazooka_PenguinPosted 12/28/2013 9:30:19 PM
Have you tried turning off the laptop and letting it cool off?

If it still has that problem, it sounds like the GPU might be damaged.
---
Deth Pen
http://i.imgur.com/eMXgU.gif
#5nIMr0D888Posted 12/28/2013 9:35:35 PM
Gpu is about to die, lower the clocks on it untill it sops working entirely.
---
CAUTION: EXTREMELY HAZARDOUS SUBSTANCE
#6Jason_Ryu_3(Topic Creator)Posted 12/28/2013 9:37:52 PM
how do I lower the clocks?
---
http://i293.photobucket.com/albums/mm80/Jason_Ryu/MS%20Paint/Jason_Ryu.jpg
Soul Silver FC: 1979 0236 8128
#7killkountPosted 12/28/2013 9:38:54 PM
well that's even more bad news for you if you didn't even over clock it.
---
http://i.imgur.com/XqIF7rn.gif
#8Jason_Ryu_3(Topic Creator)Posted 12/28/2013 9:41:25 PM
killkount posted...
well that's even more bad news for you if you didn't even over clock it.


I didn't, but a buddy of mine did for me about a year ago
---
http://i293.photobucket.com/albums/mm80/Jason_Ryu/MS%20Paint/Jason_Ryu.jpg
Soul Silver FC: 1979 0236 8128
#9DragnfyrPosted 12/28/2013 10:10:51 PM
Well lower them back to default settings and see if that works.
---
15.4" Retina MacBook Pro (Mid 2012) | Node 304 mITX | Gigabyte Z87N-WIFI | Intel Core i5-4670K | Asus GTX 760 | Corsair 1x8GB | EVGA 600W | 120+64GB SSDs
#10killkountPosted 12/28/2013 10:13:49 PM
yea, probably too much dust build up now for it to maintain those clocks at an acceptable temp.
---
http://i.imgur.com/XqIF7rn.gif