This is a split board - You can return to the Split List for other boards.

I'm having a problem with my new mouse.

#1Kano92Posted 1/24/2014 10:00:16 PM
It's a steelseries sensei raw I got in December. It's been working fine for like a month. Now for about a week now couple times a day I'll be using it normally on the desktop and all of the sudden the courser is moving erratic not smooth at all while trying to control it. The courser does move but it's very slow and moving jaggie like. I don't see any debris but it's not like I looked at it under a strong light either. Should I use a can of air on the laser ? But waiting a couple moments and moving it does fix it. Rebooting PC makes no diff. I've not played games in a over a couple weeks so I don't know if it does it while gaming but that should not be a issue. This mouse is like only 6 weeks old and it's doing this crap. I've not tinkered with the software that I Installed when I first got it either. Just odd it will work fine for hours but mess up once sometimes twice during those hours everyday now.
---
i5 2500k | ASUS P8P67 | CORSAIR 650W | 8GB DDR3 1600 | GTX 660 | 2TB 7200 RPM | Windows 7 64-bit
#2DCdemonic1Posted 1/24/2014 10:24:57 PM
Do you use a mouse pad? Laser sensors work better on rigid, hard surfaces. They don't work well with softer surfaces that most mouse pads have without causing problems like what you're stating.
#3Kano92(Topic Creator)Posted 1/25/2014 7:52:01 AM
I am using a soft pad but it's a thin one. But it was fine for like 4-5 weeks ?
---
i5 2500k | ASUS P8P67 | CORSAIR 650W | 8GB DDR3 1600 | GTX 660 | 2TB 7200 RPM | Windows 7 64-bit
#4DCdemonic1Posted 1/25/2014 8:13:08 AM
Best suggestion is to try not using that pad for a while and see if the problem persists. If you don't have problems without the pad than you know what's causing it.