This is a split board - You can return to the Split List for other boards.

steam wont run. it comes up saying "updating steam"

  • Topic Archived
  1. Boards
  2. PC
  3. steam wont run. it comes up saying "updating steam"
3 years ago#1
checking for available updates and that, but then seems to minimize/close and nothing comes up. check process and its still running but not doing anything. uninstalled and reinstalled with same results. takes about 3 minutes to kill after ending the process.
Intel i5-4750 3.2Ghz / 8GB G. Skill Ripjaw / 80 GBB HDD OS / 1.5 TB HDD / Geforce GT 630 / 500W 80+
3 years ago#2
1. Navigate to Steam's program directory. (Program Files (x86)\Steam)
2. Delete everything except for the folders and Steam.exe
3. Launch Steam.
4670k | 2GB GTX 770 OC | 8GB 1600 9-9-9-24 | 120GB SSD | 1TB WD Blue | Win8.1 Pro
http://i597.photobucket.com/albums/tt56/S26DG44B/PsythikViolet_Blooded.jpg
3 years ago#3
done. the files got replaced when i ran steam.exe but same problem, did that update check and gone while still being in my process.
Intel i5-4750 3.2Ghz / 8GB G. Skill Ripjaw / 80 GBB HDD OS / 1.5 TB HDD / Geforce GT 630 / 500W 80+
3 years ago#4
bump, does any one else one else have any idea what could be wrong? i got 2 codes from a friend who got GTX graphic cards and AC4 and splinter cell worked fine after downloading uplay for them, but when it was time for batman i couldn't get steam to work.
Intel i5-4750 3.2Ghz / 8GB G. Skill Ripjaw / 80 GBB HDD OS / 1.5 TB HDD / Geforce GT 630 / 500W 80+
3 years ago#5
Try rebooting your computer.
i5-3570K @ 4.6 GHz | HD IceQ X 7850 | Z77-D3H | 700W | Intel 550 180GB | Seagate Barracuda 1T | Seagate XTD 2T + 16GB SSHD | 2x8 GB RAM
3 years ago#6
been a few days, still steam wont open. tried reinstalling, tried deleting everything but the folders and steam.exe, tried restarting my comp even tried a full delete with a fresh install. nothing seems to be making steam open. it installed just fine on my 32bit computer, but nothing on this one.
Intel i5-4750 3.2Ghz / 8GB G. Skill Ripjaw / 80 GBB HDD OS / 1.5 TB HDD / Geforce GT 630 / 500W 80+
3 years ago#7
Have you done a virus scan? sounds like your comp is ****ed....
Everything EA contributed to gamers around the world in one youtube clip
http://www.youtube.com/watch?v=kBoesEFWZnM
3 years ago#8
All I can suggest is to make sure Steam isn't being blocked by anything. Check your firewall, anti-virus, and router exceptions. Make sure DEP is disabled or Steam is added to the exception list and you have administrator privileges.
  1. Boards
  2. PC
  3. steam wont run. it comes up saying "updating steam"

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived