This is a split board - You can return to the Split List for other boards.

Why is my 780 Ti struggling with Castlevania: LOS2 at 1440p?

#1MonkeymagePosted 2/28/2014 5:49:39 AM
Seriously. I have never once seen it hit more than 40 fps. What the hell.

Other games work fine, BF4 on Ultra runs at like 70 fps.
---
7.3 GHz Intel i9 7770k "Hollow Tree" / 64GB TDR4 RAM / GTX Titan 5 GK330 "Daghlian" Chipset, Dodeca-SLI
#2DarkZV2BetaPosted 2/28/2014 6:02:37 AM
That's pretty weird. Sounds like something is wrong. Maybe the game is bugged.
---
god invented extension cords. -elchris79
#3Bellum_SacrumPosted 2/28/2014 6:06:24 AM(edited)
It is a.console port, hence terribly optimized?

Heck, I don't know who ported it but that thing is so bad even on consoles, they had to make it sub-720p for it to stay relatively stable at 30fps.
---
"Now go ahead and leap ignorantly to the defense of wealthy game companies who don't know or care about you."
#4PhilOnDezPosted 2/28/2014 6:04:20 AM
Does it have a 'kill your performance' button like Witcher 2 does? You didn't mention any settings so it's hard to say.
---
Every time I try to go where I really wanna be it's already where I am, 'cuz I'm already there
XBL, PSN, Steam, Origin, BSN, GFAQs, MC: PhilOnDez
#5triple sPosted 2/28/2014 6:11:10 AM
I ran the demo fine in 1440p, so I don't know.
---
GT:Triple S 06
Steam ID:triples22
#6aak57Posted 2/28/2014 6:17:22 AM
PhilOnDez posted...
Does it have a 'kill your performance' button like Witcher 2 does? You didn't mention any settings so it's hard to say.

Yeah, I would look into this. For all we know you could have 32xMSAA on or something.
---
http://i.imgur.com/ULj4q.jpg
Let strength be granted, so the world might be mended.
#7protools1983Posted 2/28/2014 6:22:19 AM
Something is definitely wrong. I just saw this game maxed last night (1080p) on a GTX660 OC running smooth as butter.
---
Xbox One - The console that made me the PC gamer I am today.
Yah like dahgs?
#8MasterDonGeroPosted 2/28/2014 6:25:44 AM
How should we know? We don't know anything about your computer or settings.
---
3570K (4.5 GHz) | Dual-X 7970 | ASRock Z77 OC Formula | Corsair Vengeance 2x 4 GB | WD Black 1 TB | Corsair TX750 | XSPC Raystorm 750 RS240 Kit | NZXT Phantom
#9Monkeymage(Topic Creator)Posted 2/28/2014 6:35:10 AM
I don't remember the game having any AA settings. I'll check again later but I'm pretty sure the options consist of texture detail, DOF, etc. I didn't see any AA, AF, or AO settings.
---
7.3 GHz Intel i9 7770k "Hollow Tree" / 64GB TDR4 RAM / GTX Titan 5 GK330 "Daghlian" Chipset, Dodeca-SLI
#10Monkeymage(Topic Creator)Posted 2/28/2014 4:06:35 PM
AA settings are "High", "Low", and "Off", no mention as to the type of AA used. There's also an AF setting that is similarly labeled.

It seems to be resolved though, as I just updated the drivers to the newest WHQL ones.
---
7.3 GHz Intel i9 7770k "Hollow Tree" / 64GB TDR4 RAM / GTX Titan 5 GK330 "Daghlian" Chipset, Dodeca-SLI