This is a split board - You can return to the Split List for other boards.

VLC exe locked on Power Saving power mode in AMD CCC

#1NingishzidaPosted 3/7/2014 5:13:39 PM
The AMD CCC switchable graphics on my laptop allows me to bring up a list of apps with a drop-down selector where I can assign a power mode on a by-app basis.

The selections are: Not Assigned, Based on Power Source, High Performance and Power Saving.

Now some apps are ghosted and locked by default, for example VLC, and I can't edit the drop-down box to High Performance, its stuck on Power Saving. This wouldn't concern me except for the fact that when I play movies VLC occasionally pixelates and "chromes" them as a result of the power saving.

When I create a new profile, it again auto-locks the power mode to Power Saving again.

My system is on a Balanced plan which maxes all gfx performance, as far as I can see.

Yes, VLC sucks ass and swallows blah blah, I don't give a rat's arse, but does anyone know how to override this?

Also, why put an app like that on Power Saving by default, it seems senseless? I notice by default IE is on Power Saving, too, but is not locked.
#2squarenixfan119Posted 3/7/2014 6:08:11 PM
Is CCC updated?
---
http://www.speedtest.net/result/2705976737.png
#3ClouddxPosted 3/7/2014 6:17:07 PM
It's VLC that's causing the issue, just use something different.
---
i7-920 @ 3.6 // 770 GTX // 12 GB G.Skill Sniper Ram // PS3 // 360
FiiO e9+17 // AD700 + M50 // Deck Legend + 82 // DAS Ultimate S
#4Ningishzida(Topic Creator)Posted 3/7/2014 6:17:34 PM
Yeah, and so is VLC.

Been googling more and don't see any threads where this was solved, i just want VLC to use the dgpu instead of igpu so hardware accelerated decoding and whatnot work as they do on my desktop (the vids I'm playing run flawlessly on the desktop).

Seems like a senseless default setting, I don't see any reason why they'd lock it on Power Saving...
#5Ningishzida(Topic Creator)Posted 3/7/2014 6:18:42 PM
Clouddx posted...
It's VLC that's causing the issue, just use something different.


I will just use MPC, but I wouldn't mind an explanation if anyone knows.
#6ClouddxPosted 3/7/2014 6:21:24 PM(edited)
Ningishzida posted...
Clouddx posted...
It's VLC that's causing the issue, just use something different.


I will just use MPC, but I wouldn't mind an explanation if anyone knows.


I couldn't tell you, but I've never been able to fix the issue. Happens all the time on my laptop.
---
i7-920 @ 3.6 // 770 GTX // 12 GB G.Skill Sniper Ram // PS3 // 360
FiiO e9+17 // AD700 + M50 // Deck Legend + 82 // DAS Ultimate S
#7Ningishzida(Topic Creator)Posted 3/7/2014 6:28:09 PM
I renamed the exe and it seems to accept it and allow High Performance, and CCC replaced the original vlc.exe listing, but I won't know if that's a true fix until I watch a whole movie (used to happen about once per 30 mins for 3 secs).

Time will tell.
#8Ningishzida(Topic Creator)Posted 3/8/2014 1:06:23 PM
ok renaming the exe to assign a different power mode didn't work

what a sad little app VLC is, MPC doesn't have this prob.

never installing VLC again