This is a split board - You can return to the Split List for other boards.

Any idea why hdmi to hdmi doesn't work but hdmi to dvi does? Laptop question...

#1Sipher360Posted 3/15/2014 6:34:42 PM
The weirdest thing has happened. I hadn't used this laptop in a while. I got it out updated all the drivers and everything. Hit it with some compressed air to clean it up a bit. Plug it into my monitor via hdmi, and nothing happens. It simply would not read. Got another monitor, same thing. Tried it with four monitors.

I decided then to get out my hdmi to dvi cable and connected it via hdmi-dvi and it works then, no problem. Very strange.

Has anyone ever heard of this problem with a laptop using hdmi-out. I've tried all of the following:

1. Uninstall then re-install Nvidia graphics driver.
2. No need to disable the Intel graphic card b/c there isn't one, to my knowledge (it's a Sony Vaio F series laptop).
3. Tried activating the HDMI sound option under the volume controls but it says "No HDMI Sound Device Connected" or something like that. It says this same thing in the Nvidia control panel.

This is really strange. Not a problem b/c I can just use my DVI port, but I would like to at least know what went wrong. Any advice is appreciated. Thanks.
---
"Now senators are getting high....and your plan against the ghetto back-fired..."--Ice Cube
#2DoramiPosted 3/15/2014 7:50:16 PM(edited)
Did you get your driver from nVidia or from Sony? Sony uses vendor modified drivers for their laptops, which are not compatible with nVidia's stock drivers.

Try using the latest driver from Sony's website.
---
3DS FC: 1246-9917-4900 | Pokemon X: IGN: Jing | Safari: Ground: Phanpy, Camerupt, Diggersby
NNID: StareRoe | PSN: Raftina
#3Sipher360(Topic Creator)Posted 3/15/2014 7:55:52 PM
Really? Ok, I'm going to try that now. Is there any chance there could be a hardware problem that allows hdmi to carry video but not audio? Have you ever heard of such a hardware failure. I'm off to the Sony site now to find drivers there. Thanks again.
---
"Now senators are getting high....and your plan against the ghetto back-fired..."--Ice Cube
#4DoramiPosted 3/15/2014 8:20:25 PM
By the way, when you say your HDMI to DVI cable works, which side is plugged into the laptop, and which side is plugged into the monitor?
---
3DS FC: 1246-9917-4900 | Pokemon X: IGN: Jing | Safari: Ground: Phanpy, Camerupt, Diggersby
NNID: StareRoe | PSN: Raftina
#5Sipher360(Topic Creator)Posted 3/15/2014 8:21:47 PM
Well, I went to the Sony site and downloaded the audio drivers for my machine as well as the patch. Unfortunately, that still didn't work. It still fails to connect to my monitors via hdmi. Crazy because up until I last used it, it was still working. I have no pets or children around. It was just sitting dormant for a while. Nothing should have happened to it and it's in excellent shape.

Any other recommendations?
---
"Now senators are getting high....and your plan against the ghetto back-fired..."--Ice Cube
#6DoramiPosted 3/15/2014 8:25:09 PM
Did you mean you got the video card drivers?
---
3DS FC: 1246-9917-4900 | Pokemon X: IGN: Jing | Safari: Ground: Phanpy, Camerupt, Diggersby
NNID: StareRoe | PSN: Raftina
#7Sipher360(Topic Creator)Posted 3/15/2014 8:25:29 PM
Dorami posted...
By the way, when you say your HDMI to DVI cable works, which side is plugged into the laptop, and which side is plugged into the monitor?


My laptop has hdmi out on it and my monitor has DVI in. I am running HDMI from my laptop into my DVI on my monitor. It works with absolutely no problem. But if I try HDMI to HDMI then it won't work. For some reason, I think it has to do with the audio drivers.
---
"Now senators are getting high....and your plan against the ghetto back-fired..."--Ice Cube
#8DoramiPosted 3/15/2014 8:29:41 PM
Try using the video card drivers from Sony.
---
3DS FC: 1246-9917-4900 | Pokemon X: IGN: Jing | Safari: Ground: Phanpy, Camerupt, Diggersby
NNID: StareRoe | PSN: Raftina
#9Sipher360(Topic Creator)Posted 3/15/2014 8:35:20 PM
Yes, I downloaded those as well. It took me back to the original drivers that came with the machine. That didn't work either. Thanks for the recommendation. Very confusing situation here. Nothing on the internet seems to point in the direction of the problem.
---
"Now senators are getting high....and your plan against the ghetto back-fired..."--Ice Cube
#10Davel23Posted 3/15/2014 8:41:11 PM
Have you tried a different HDMI cable?
---
Your mom's box.