This is a split board - You can return to the Split List for other boards.

Games keep crashing... not sure what it could be?

#1phudabulahPosted 3/26/2014 2:06:51 PM
Hello,
So whenever I play games they keep crashing. Doesn't seem to matter what game, I've tried Torchlight 2, Starcraft 2, League of Legends, Team Fortress 2 and they all have been crashing. When LoL crashed it actually went Blue Screen and my computer restarted on its own.

My computer is almost 5 years old...

Specs:
GPU - Radeon HD4890
RAM 8 gigs
Mobo - ASUS M4A785TD
CPU - AMD Phenom II X4 945 3.0GHz Quad Core
650W PSU

I tried using CoreTemp, but it says the temps are all 0 :/ not sure why it says that... I've also run MSE, MalwareBytes and Spybot and nothing came up. Any ideas where to start?
---
No one cared who I was till I put on the mask...
#2SlaynPosted 3/26/2014 2:08:45 PM
Update video card drivers.
---
You can spend $400 on a console and $400 on a cheap PC, or you can spend $800 to build your own and have the best of both worlds.
#3godplaysSNESPosted 3/26/2014 2:11:32 PM
Are you experiencing performance problems, or visual glitches prior to the crashes?
---
Super Mario Kart is the single best Mario Kart ever!
#4codyorrPosted 3/26/2014 2:12:40 PM
Graphics card failing?
#5phudabulah(Topic Creator)Posted 3/26/2014 2:15:08 PM
Oh yeah I forgot to mention the drivers are updated...

No not any performance issues I can think of. My screen will just go black for a few seconds and crash to the desktop, or in LoL's case it completely restarted.
---
No one cared who I was till I put on the mask...
#6JKatarnPosted 3/26/2014 4:16:52 PM
phudabulah posted...
Oh yeah I forgot to mention the drivers are updated...

No not any performance issues I can think of. My screen will just go black for a few seconds and crash to the desktop, or in LoL's case it completely restarted.


Have you tried running MemTest86 to check your RAM? Corrupted/unstable RAM could cause problems like this. That, or it's a power supply issue.
---
Asus P8Z68-V LE | Core i7 2600K | 8GB G.Skill Ripjaws DDR3 | Gigabyte GeForce GTX 660 Windforce OC
PS3 | PS2 | PSP| Wii | 3DS | DS | X-Box 360 | X-Box | NES
#7phudabulah(Topic Creator)Posted 3/27/2014 11:00:34 AM
I'll try that right now thanks!

Also, I was just playing StarCraft 2 and it *nearly* crashed, it completely froze for ~10 seconds then went black and then some weird fuzzy tv-staticesque appeared on my screen. But it then resumed playing as normal.
---
No one cared who I was till I put on the mask...
#8JKatarnPosted 3/27/2014 12:09:00 PM
phudabulah posted...
I'll try that right now thanks!

Also, I was just playing StarCraft 2 and it *nearly* crashed, it completely froze for ~10 seconds then went black and then some weird fuzzy tv-staticesque appeared on my screen. But it then resumed playing as normal.


That's not good....sounds like a hardware/driver issue. If the MemTest comes up clean, I would download the "Unigine Valley" benchmark, running it at ultra settings to really stress your card and monitor your temps (the benchmark displays FPS/GPU temp) as you let it run for at least a few hours. If your temps are fine, you see no corruption have no crashes than it's not a GPU issue.
---
Asus P8Z68-V LE | Core i7 2600K | 8GB G.Skill Ripjaws DDR3 | Gigabyte GeForce GTX 660 Windforce OC
PS3 | PS2 | PSP| Wii | 3DS | DS | X-Box 360 | X-Box | NES
#9phudabulah(Topic Creator)Posted 3/27/2014 12:53:34 PM
Yeah the MemTest86 said no errors... I'm downloading the Unigine Valley benchmark right now, but with my internet this could take a while.

Also about the drivers, it's kind of confusing. When I go into Control Panel-->Device Manager-->right click on my GPU, it says my drivers are all up to date with year of 2011.

However when I downloaded them from AMD's website the website says it's from 2013. Is my computer confused about the drivers maybe?
---
No one cared who I was till I put on the mask...
#10phudabulah(Topic Creator)Posted 3/27/2014 1:57:43 PM
I'm running Unigine Valley on ultra settings and the GPU temp is hovering around 82 Celsius. I'm guessing that's a little high? FPS is around 12-15 lol...
---
No one cared who I was till I put on the mask...