This is a split board - You can return to the Split List for other boards.

I need help diagnosing what's wrong with my PC.

#1snae99Posted 4/11/2014 10:56:10 AM
I posted a topic before but it kinda closed. Here's the link to it, it basically has all the info of what is going on:

http://www.gamefaqs.com/boards/916373-pc/68919972


I ran memtest for 6 passes and there were no errors so I honestly don't know what else it could be.

Now I haven't gotten the blue screen again, but my computer still freezes randomly at times. I went a week without it freezing until it froze again last night (I was just browsing and it just... froze).

Specs:
i5 2500k (not oc'd yet)
GTX 560ti
8gb RAM
620w PSU

Should I run any other tests to rule out my other parts? I personally don't think it's my graphics card or CPU but couldn't hurt to try I suppose...
---
Currently playing: Chrono Trigger
#2drinkPosted 4/11/2014 10:58:16 AM
if its not the memory, its the driver
---
You didn't try google, you made that up...
Twist those dirty bags - Shake
#3machetemanPosted 4/11/2014 10:59:27 AM
What nvidia drivers are you using? Anything after 314.20 and before 332.xx causes freezes/lock up (during browsing among other things) with all 400/500 series cards.

I recommend getting the latest nvidia drivers.
#4snae99(Topic Creator)Posted 4/11/2014 11:06:20 AM
Nvidia drivers are 331.82... I could have sworn I was up to date already. I really appreciate the help guys! Hopefully this resolves my issues.
---
Currently playing: Chrono Trigger
#5DarkZV2BetaPosted 4/11/2014 11:19:43 AM
Please list the model of your PSU and motherboard.
---
god invented extension cords. -elchris79
Starcraft 2 has no depth or challenge -GoreGross
#6snae99(Topic Creator)Posted 4/11/2014 11:44:42 AM
PSU: Antec HCG M Series HCG-620M 620W ATX12V / EPS12V SLI Ready CrossFire Ready 80 PLUS BRONZE

http://www.newegg.com/Product/Product.aspx?Item=N82E16817371059


Motherboard: GIGABYTE GA-Z68MA-D2H-B3 LGA 1155 Intel Z68 HDMI SATA 6Gb/s USB 3.0 Micro ATX Intel

http://www.newegg.com/Product/Product.aspx?Item=N82E16813128495
---
Currently playing: Chrono Trigger
#7CELTEKKPosted 4/11/2014 11:52:20 AM
check your drivers for your RAM.

might have to reinstall.
---
psn:celtekk|steam:celtekk
3770k@4.8
#8snae99(Topic Creator)Posted 4/11/2014 12:00:07 PM
There are RAM drivers? >_>
---
Currently playing: Chrono Trigger