This is a split board - You can return to the Split List for other boards.

PC gets mega loud playing Far Cry 3 and Metro Last Light

#1KOTRwhoopsPosted 4/28/2014 5:19:21 PM
Hi all,

I've had my PC now for 18 months and it's superb. I can max most games no problem. However when playing Far Cry 3 or Metro LL the fans and graphics cards go crazy when on max/very high. I've tried fiddling with the settings but it doesn't seem to help much. Lowering what settings in these games will possibly stop the graphics cards and intake fans going into overdrive? I notice both cards in my setup are reaching around 80C playing these games. (full specs below)

The main reason I worry is because I want to get Watchdogs for the PC and if it's going to make that noise on high settings I'm going to get annoyed when playing it.

When I play other so called demanding games like The Witcher 2 (less ubersamplaing) and Crysis 2 (maxed) I have no issues with the cards going crazy.

Any helpful replies greatly appreciated. Thanks for any help.

Intel Core i5 3570K Processor Overclocked to up to 4.4GHz
Akasa Venom Voodoo Ultra Quiet CPU Cooler
Asus P8Z77-V Motherboard
8GB Corsair PC3-12800 1600MHz DDR3 Memory (2 x 4GB sticks)
Gainward NVIDIA GeForce GTX 670 2048MB Graphics Card SLI
Gainward NVIDIA GeForce GTX 670 2048MB Graphics Card SLI
240GB Corsair Force 3 Solid State Drive
2000GB 7200RPM Hard Disk - 6Gbps
Corsair CX 750W 80 PLUS Bronze Certified PSU
Windows 7 Home Premium 64 bit
24" Asus VS247H Widescreen LED Monitor 1080p

---
PLAYING - Titanfall (XBO), Infamous SS (PS4), Final Fantasy X (PS3)
PSN / XBL / NN - Robioto, STEAM - Robioto555
#2SpacewhizguyPosted 4/28/2014 5:55:48 PM
Get an aftermarket cooler if you truly care about noise.
---
What's a sig?
#3stevo_392Posted 4/28/2014 7:13:56 PM(edited)
is it that high pitch noise u get when ur fps is in the thousands?

edit: nvm didn't read the part about the fans
#4WyzeGyePosted 5/1/2014 1:43:38 AM
If they're hitting 80c, you should maybe try to get better airflow in your case.
---
http://puu.sh/8hi9W/9082c43c30.png
#5XerocagePosted 5/1/2014 1:56:13 AM
WyzeGye posted...
If they're hitting 80c, you should maybe try to get better airflow in your case.


This, my case has terrible air flow but still at full load I only get as high as 67c during the summer when its 40c outside.

Another thing if you havnt allready, set a custom fan profile. I have mine set to match temps, 40c = 40%, 60c = 60% etc.
one thing that I should add is that my card has a blower type fan in that if expels thr hot air out the back as aposed to into the case.
#6josh_bPosted 5/1/2014 3:18:32 AM
I had a similar problem when i had 2 GTX 670's in my case and the filters i had on my case and i wasn't getting enough airflow. Ended up adding larger fans to the side and top of the case which helped out alot and cut back on the cards fans spooling up so much. My cards had reference coolers on them.
---
i5 2500k 4.5GHZ OC, 32GB DDR3, PNY GTX 780TI SLI, MSI P67A-GD55 Mobo, 128GB SSD, Barracuda Green 1.5TB HDD updating to i7 shortly
Xbox live: tanis8585
#7phy2jshPosted 5/1/2014 3:49:06 AM
Assuming you have a 60hz monitor, you could reduce graphics settings to the point where you get over 60 fps, then turn on vsync. This should stop your GPUs from running at 100%.
#8KOTRwhoops(Topic Creator)Posted 5/1/2014 11:20:21 AM(edited)
phy2jsh posted...
Assuming you have a 60hz monitor, you could reduce graphics settings to the point where you get over 60 fps, then turn on vsync. This should stop your GPUs from running at 100%.


Thanks everyone.

I always have v-sync on actually so that isn't the issue. But I do have a couple of 120mm fans kicking around so I might add them to see if that helps. I'll also have a play with my fan settings.
---
PLAYING - Dark Souls II (PC), Child Of Light (PS4), Final Fantasy XIV (PC)
PSN / XBL / NN - Robioto, STEAM - Robioto555
#9Lemur_HPosted 5/1/2014 3:17:50 PM
Your cards are likely running at max or near max GPU usage. They're working hard so they are generating more heat. More heat = more noise. Not much can be done besides making sure they are clean or replacing them entirely with more powerful cards that won't max out so soon. You can try turning off major GPU hogs like ambient occlusion and anti-aliasing. Do that and the cards won't need to work nearly as hard to maintain 60 FPS.

Your room temperature will also have a huge impact on your hardware temperature. Play long enough in a warm room and your system will only heat up more and more because it can't take in cool air. This gets quite bad in the summer, even with my AC on.
#10Lonestar2000Posted 5/1/2014 3:52:06 PM
Spacewhizguy posted...
Get an aftermarket cooler if you truly care about noise.

This, I have a GPU that came with a stock blower-type cooler that got really loud under load so I bought an aftermarket one.
---
Rumble Roses. Someone enters the room.
Them: O_O Me: What?! I always play games without my pants on!- Inmate 922335