This is a split board - You can return to the Split List for other boards.

Steam wishlish language

#1dlfPosted 7/17/2014 11:02:13 AM
Just checked my wishlist and the language was Germanic, not English or something else, nor had I set it to Germanic. Reset my password? There may be (though not certain) some games in my wishlist that I didn't put in it.
---
I have built http://pcpartpicker.com/p/gFKkgs - Minus a few parts (monitor @ moment). Screw trying to record video (on PC).
#2Englandfc1966Posted 7/17/2014 11:08:39 AM
English is a Germanic language..
---
Steam: Buffalosoulja
#3kobalobasileusPosted 7/17/2014 11:09:36 AM
I have had this happen to be before (though the language was Korean). It's just a Steam glitch, nothing to worry about.
#4xanthan1Posted 7/17/2014 11:10:37 AM(edited)
Well wait, was it doing it in the Steam client or the Steam website?

I've had it happen before, but usually on a community made.
#5MaxCHEATER64Posted 7/17/2014 11:11:34 AM
Englandfc1966 posted...
English is a Germanic language..


yeah but american isn't
---
https://i.imgur.com/6sZC0hY.png
"Some people have skeletons in their closets. I just have a bone in my pants." -Mitchell2003
#6dlf(Topic Creator)Posted 7/17/2014 11:17:41 AM
The actual website, I almost never use the client to browse, set the language to Japanese (for both wishlist and the main site) . . . .
---
I have built http://pcpartpicker.com/p/gFKkgs - Minus a few parts (monitor @ moment). Screw trying to record video (on PC).
#7MyDogSkipPosted 7/17/2014 12:12:20 PM
MaxCHEATER64 posted...
Englandfc1966 posted...
English is a Germanic language..


yeah but american ain't


ftfy
---
Don't trust the smiling penguin!
http://backloggery.com/mydogskip93
#8BlueswordsXPosted 7/17/2014 12:15:52 PM
MaxCHEATER64 posted...
Englandfc1966 posted...
English is a Germanic language..


yeah but american isn't

*insert Bandit Keith joke*
---
Touhou is love. Welcome to Gensokyo!
#9RhapsoKnightPosted 7/17/2014 12:23:12 PM
If you use a link from someone else to Steam's website it will usually keep that person's language setting in the link, thus changing your default language to their's. Kind of annoying but nothing to worry about.
#10Killah PriestPosted 7/17/2014 12:27:52 PM
following a link and setting the language again to english in the top right corner fixes it sometimes.
---
Laugh, and the world laughs with you. Weep, and you weep alone.
The armory of god is guarding me but all you can see is holographic artistry.