This is a split board - You can return to the Split List for other boards.

The HD 7950 I just got will not show any video. Why?

  • Topic Archived
  1. Boards
  2. PC
  3. The HD 7950 I just got will not show any video. Why?
1 year ago#11
phantasy posted...
have you try re-seating the card?

Done that about 5 times now.
I even thought that it was the psu, but I changed it for a good Rosewill 550w psu and still nothing.
When a I put the old video card back in it works as it should.
Am I confused,
I even thought that the bios switch was wrong, but it on 2 which the right in according to online.
I just wish that it work work like any other card normally world.
I am frustrated.
---
Xbox360/One + PS3/4 + Wii U + PC = Awesomeness!!!
1 year ago#12
Snadados posted...
See if your BIOS is set to UEFI or Legacy.

Only two option on the Powercolor PCS+ HD 7950 which are 1 or 2, and 2 is default.
---
Xbox360/One + PS3/4 + Wii U + PC = Awesomeness!!!
1 year ago#13
Sorry, I meant your motherboard's bios.
---
Have you accepted Raspberyl as your loli and savior?
1 year ago#14
Snadados posted...
Sorry, I meant your motherboard's bios.

I have never touched that on my mobo, and it has been on the same setting since I bought it. Hell, I don't even know where that is.
---
Xbox360/One + PS3/4 + Wii U + PC = Awesomeness!!!
1 year ago#15
ghstbstr posted...
phantasy posted...
have you try re-seating the card?

Done that about 5 times now.
I even thought that it was the psu, but I changed it for a good Rosewill 550w psu and still nothing.
When a I put the old video card back in it works as it should.
Am I confused,
I even thought that the bios switch was wrong, but it on 2 which the right in according to online.
I just wish that it work work like any other card normally world.
I am frustrated.


which model rosewill psu is it? and what was the other psu model. Its necessary to determine if the psu can actually deliver the power it advertises.
---
FX 8320 | XFX 280X | 8GB | GA-990FXA-UD5 | EVO 250GB | 3TB | HX620 | Carbide 200r
1 year ago#16
This topic here has someone with similar issues and has pictures of what the bios screen will look like.

http://www.eightforums.com/graphic-cards/18650-my-video-card-fails-operate-under-uefi.html

It would be best if you searched exactly how to do this with your motherboard.

If you haven't done so I'd look into updating your motherboards bios.
There may have been an update for it that fixes your problem.
---
Have you accepted Raspberyl as your loli and savior?
  1. Boards
  2. PC
  3. The HD 7950 I just got will not show any video. Why?

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived