This is a split board - You can return to the Split List for other boards.

Is it normal that my "gaming" laptop is running games like poop?

#1Dragonfire4356Posted 8/5/2014 8:04:11 PM
Its an alienware m14x R2

i7
16 gigs ram
Geforce 650m



Diablo 3 is choppy no matter what settings i put it on
Wargame Red Dragon barely runs on low


I made sure its plugged in and on high performance mode too. Drivers are updated as well.
#2alsroboshackPosted 8/5/2014 8:05:36 PM
insert "gaming laptops don't exist" comment here.
---
some people treat life as a game,
some people treat games as life.
#3SpazH3dPosted 8/5/2014 8:08:07 PM
Gaming laptops don't exist, brah.
---
- My vision is augmented
#4PsythikPosted 8/5/2014 8:09:12 PM
[This message was deleted at the request of the original poster]
#5ivanderlandPosted 8/5/2014 8:12:32 PM
Red Dragon is weird as far as optimizations go to begin with. It may be a stupid suggestion, but make sure it's not using the integrated gpu with Diablo. It kept defaulting to integrated for me.
#6hk7111Posted 8/5/2014 8:12:50 PM
Are you sure its using the 650m and not whatever Intel HD it has? i know sometimes they decide "Hmm a game you say? Lets run it on the crap Intel HD thing instead of the half decent Card"
---
Steam: Hk1777, Gtag: RAlNB0W D4SH (Yes its an L) Psn: hk1777
PC, PS3, PS2, PS Vita, 3DS, Xbox 360, Wii, Ipad, 17 Kyocera Hydros, LG G3
#7Dragonfire4356(Topic Creator)Posted 8/5/2014 8:14:45 PM
Actually im not sure if its using the 650 and not the integrated. How do i make sure?
#8Hi CPosted 8/5/2014 8:20:03 PM(edited)
Diablo 3 constantly streams from your HDD due to the always online DRM scheme so if they put a cheap low quality 5400rpm one in there it's going to suck.

D3 will also kill the s*** out of your drive for the same reason. Look forward to lots of bad sectors soon.
#9PsythikPosted 8/5/2014 8:29:27 PM
Hi C posted...
Diablo 3 constantly streams from your HDD due to the always online DRM scheme so if they put a cheap low quality 5400rpm one in there it's going to suck.

D3 will also kill the s*** out of your drive for the same reason. Look forward to lots of bad sectors soon.
Curious.

Is that the case with StarCraft II as well?
---
4670K OC | 2GB PNY GTX 770 OC | 8GB 1600 | 120GB SSD | 1TB WD Blue | Gigabyte Z87MX | EVGA 600w | BitFenix Phenom M | Win8.1 Pro
http://imgur.com/KaTyP5o.jpg
#10Dragonfire4356(Topic Creator)Posted 8/5/2014 8:58:01 PM
So i tried wargame again, but this time i had gpuz running in the background. I minimized while the game was running and it showed that the 650m had 0 percent load. WTF