This is a split board - You can return to the Split List for other boards.

Wow PC San Andreas is crazy unoptimized..

#11stevo_392Posted 8/12/2014 10:24:09 PM
turn off frame limit and enable v sync.
#12gamefaqwatcherPosted 8/12/2014 10:36:19 PM
It runs perfect and better on my cheap laptop than on the ps2. Not sure what is wrong with your game. I recall downloading a patch from somewhere. Although i think it was a requirement for MTA which was a lot of fun.
---
You're the hero Gamefaqs deserves, but not the one it needs right now.
#13Madmicky933Posted 8/12/2014 10:50:42 PM
Topic Creator, I have this game on my PC and I know how to make it run perfectly.

You need update 1.0.1 to get 1080p.

And if you have a NVIDIA card, use NVIDIA Control Panel to enable Vsync for San Andreas. This will keep the game at 60fps.

The game runs perfectly at 60fps.

Just make sure that, in the game Display settings, you disable Frame Limiter.


This also goes for both GTA 3 and GTA Vice City. They both have the same problem.
---
Karma... Is a powerful force..
#14grimsmalicence(Topic Creator)Posted 8/12/2014 11:04:25 PM
Already did have all those things guys. I have 1080p, the game is locked at 60 fps through MSI Afterburner, I have Vsync enabled through CCC and I disabled frame limiter. Still wonky physics and swimming is slow. Are you sure swimming is normal for you? Because I notice a clear difference when trying to swim with frame limiter disabled and it enabled.
---
there's no present like the present
#15LikeGoodMorningPosted 8/13/2014 12:12:47 AM
Games that come to console first and later on pc always can possibly have the games physics get messed up past 60 fps. Which is why 4k 60ps>>>>>>> 1080p 120fps all dang day.
#16RhapsoKnightPosted 8/13/2014 5:40:40 AM(edited)
Look for SilentPatch on GTAforums. It fixes a bunch of things in the PS2-era GTAs, one being the frame limiter being wrongly limited to 25 instead of 30 and makes the game run better overall with the frame limiter off when vsync'd to 60 as well.
The patch for San Andreas is still in beta so you have to dig in the last few pages of the thread though but it's well worth it

Edit: Here. http://gtaforums.com/topic/669045-reliiivcsaasi-silentpatch/page-27#entry1065600043
You also need Silent's asi loader, easily found on GTAgarage and you have to downgrade to 1.00.
#17tigerex777Posted 8/13/2014 5:33:37 AM
Fade2black001 posted...
I don't know.... My friend runs the game at 1080P with near max settings on 645.


Fake, the game doesn't natively support 1080p resolution so you have to make a lot of changed just too have to play in 1080p. Then it you run the game above 30fps you get glitches. Then the game has mouse bug problems. Just like all Rockstar PC games San Andres is super in optimized for PC
---
i5 4670k @ 4.2ghz / 8GB DDR3 Ripjaws / GTX 770 SLI / Cooler Master GX 750W / Cooler Master CM 690 ADVANCE II case / Asus 24' 144hz / Gigabyte Z97X Gaming 7 mobo
#18RhapsoKnightPosted 8/13/2014 5:36:24 AM
^1.01 does. For whatever reason the Steam release is based on 1.00.
#19grimsmalicence(Topic Creator)Posted 8/13/2014 1:39:22 PM
RhapsoKnight posted...
Look for SilentPatch on GTAforums. It fixes a bunch of things in the PS2-era GTAs, one being the frame limiter being wrongly limited to 25 instead of 30 and makes the game run better overall with the frame limiter off when vsync'd to 60 as well.
The patch for San Andreas is still in beta so you have to dig in the last few pages of the thread though but it's well worth it

Edit: Here. http://gtaforums.com/topic/669045-reliiivcsaasi-silentpatch/page-27#entry1065600043
You also need Silent's asi loader, easily found on GTAgarage and you have to downgrade to 1.00.


Hmm, will my saves work if I downgrade to 1.00?
---
there's no present like the present
#20xanadooPosted 8/13/2014 1:49:54 PM
This makes me worried for GTAV. sigh.