This is a split board - You can return to the Split List for other boards.

Blurry picture on Monitor

#1DetectiveZPosted 8/26/2014 3:23:11 PM
Hello!
I wanted to try and dual monitor, however one of my screens is extremely blurry with washed out colours.

I'm assuming this is the TV I'm using as a monitor
http://www.thesource.ca/estore/product.aspx?product=8000333&language=en-CA
(Bought it long ago at a garage sale, threw away the box.)

I tried to prtsq to show you, but it looks perfectly find on my other monitor.
I'm guessing the problem is with my TV, but I can find no option to change the settings besides the usual. (None of the settings fixes it: Sharpness, Brightness, Contrasts.)

The funny thing also as well, when I plug my PS3 through HDMI, it works perfectly well.
1080p and no blurry/washed out colours.

However, if I plug it to my PC. My native resolution turns into 1680x1050.

What should I do?

*My Graphics Card is a GTX 770
Thanks in advance.
---
3DS FC: 1504-5928-8042
Krabby, Poliwhirl and Floatzel
#2WerdnAndreWPosted 8/26/2014 3:27:28 PM
Is the TV in extended mode and set to 1920x1080?
---
Corsair 500r_P8Z68-V Pro_2500k_Hyper 212+_Corsair 2x4gb_TX750w v2_MSI 780 Lightning_F3 1TB_Crucial M4 128GB_Xonar DG_Tt Meka G1_Asus PA248Q
#3DetectiveZ(Topic Creator)Posted 8/26/2014 3:31:07 PM
Extended Mode?
And no, apparently my TV is only "1680x1050", when I tried changing it to 1920 x 1080p, It stays the same, but I can't see everything on the screen. Almost like all it did was zoom in.
---
3DS FC: 1504-5928-8042
Krabby, Poliwhirl and Floatzel
#4WerdnAndreWPosted 8/26/2014 3:34:08 PM
In the display options you can set the 2nd monitor as cloned or extended, use extended. Set the TV to 1080p and the TV should have a aspect ratio button. Set it to 1:1 or just scan, it might be named differently.
---
Corsair 500r_P8Z68-V Pro_2500k_Hyper 212+_Corsair 2x4gb_TX750w v2_MSI 780 Lightning_F3 1TB_Crucial M4 128GB_Xonar DG_Tt Meka G1_Asus PA248Q
#5DetectiveZ(Topic Creator)Posted 8/26/2014 3:37:59 PM
Yeah, I'm on extended mode.
How exactly do I setup the TV to 1080p?
I can't find an option in the menu to do it.
(I somehow can't access the advanced menu. (Greyed out.))

The aspect ratio still doesn't change anything much.
If I change it to 1:1, it still looks bleached and blurry.
---
3DS FC: 1504-5928-8042
Krabby, Poliwhirl and Floatzel
#6WerdnAndreWPosted 8/26/2014 3:44:47 PM
Change the resolution to 1920x1080. In your video card control panel, make sure over scan is set to 0%.
---
Corsair 500r_P8Z68-V Pro_2500k_Hyper 212+_Corsair 2x4gb_TX750w v2_MSI 780 Lightning_F3 1TB_Crucial M4 128GB_Xonar DG_Tt Meka G1_Asus PA248Q
#7LordSeiferPosted 8/26/2014 3:46:45 PM
maybe its only 720p and that page is incorrect.

1080p for an offbrand 22 inch tv would be surprising
---
^ this
#8DetectiveZ(Topic Creator)Posted 8/26/2014 3:57:15 PM(edited)
How do I check for overscan?
I tried readjusting the screen in the nvidia control panel but it didn't work either.
I also tried changing to lower resolutions, but still the same problem remains.
640, 720

Weird though that when I plug in my PS3 it upscales to 1080p perfectly fine.
---
3DS FC: 1504-5928-8042
Krabby, Poliwhirl and Floatzel
#9WerdnAndreWPosted 8/26/2014 3:58:56 PM
I'm not at home so I can't tell you where the overscan option is. Its there somewhere.
---
Corsair 500r_P8Z68-V Pro_2500k_Hyper 212+_Corsair 2x4gb_TX750w v2_MSI 780 Lightning_F3 1TB_Crucial M4 128GB_Xonar DG_Tt Meka G1_Asus PA248Q
#10IzicialPosted 8/26/2014 4:01:05 PM
If your TV isn't ment to display 1080p then it likely can't try and set it to the native resolution of the TV.
---
Check out my SL 1 playthrough of Dark Souls II on my channel Izzy Games.
http://www.youtube.com/playlist?list=PL19gU5IpjVkl-9LtY2ASx8ouTspMrGfN_