This is a split board - You can return to the Split List for other boards.

How can I get my headset to work in another USB Port?

#1ajko000Posted 8/29/2014 3:51:56 PM
I've tried shutting down, unplugging, and both along with actually turning my PSU off.

How do I fix this? It won't detect under the sound devices, although it shows up as "Unspecified" under "Devices And Printers".
---
I have OCD, so I close all my topics once I'm done with them.
#2Rolen47Posted 8/29/2014 4:02:08 PM
Do you need to install drivers?
#3ajko000(Topic Creator)Posted 8/29/2014 4:03:12 PM
Rolen47 posted...
Do you need to install drivers?


They were installed ages ago, but as soon as I switch the port, BOOP! Nothing.
---
I have OCD, so I close all my topics once I'm done with them.
#4WyzeGyePosted 8/29/2014 4:22:25 PM
reinstall the drivers.
---
http://puu.sh/8IK8Q/8e25ebacb7.jpg - - http://steamsignature.com/profile/english/76561198039262606.png
Wolves don't lose sleep over the opinions of sheep.
#5ajko000(Topic Creator)Posted 8/29/2014 4:27:34 PM(edited)
http://i.imgur.com/WTk82HI.png

Now, do I want to check that? I'm on Windows 7. I ask because I hit, "Uninstall" but then it gives me that. Does that mean it will uninstall the drivers from my device as well as my computer? Or just my computer?
---
I have OCD, so I close all my topics once I'm done with them.
#6WyzeGyePosted 8/29/2014 4:28:32 PM
Your device doesnt have drivers, it has firmware. Yes, uninstall the driver software. then reinstall it.
---
http://puu.sh/8IK8Q/8e25ebacb7.jpg - - http://steamsignature.com/profile/english/76561198039262606.png
Wolves don't lose sleep over the opinions of sheep.
#7ajko000(Topic Creator)Posted 8/29/2014 4:40:36 PM
WyzeGye posted...
Your device doesnt have drivers, it has firmware. Yes, uninstall the driver software. then reinstall it.


Didn't work.
---
I have OCD, so I close all my topics once I'm done with them.
#8WerdnAndreWPosted 8/29/2014 4:44:28 PM
ajko000 posted...
http://i.imgur.com/WTk82HI.png

Now, do I want to check that? I'm on Windows 7. I ask because I hit, "Uninstall" but then it gives me that. Does that mean it will uninstall the drivers from my device as well as my computer? Or just my computer?


Yes, check the box. When you plugged it back in, did it say it was installing drivers?
---
Corsair 500r | P8Z68-V Pro | 2500k 4.4ghz | Hyper 212+ | Corsair 2x4gb | TX750w v2 | MSI 780 Lightning | 1TB HDD | Crucial M4 128GB | Xonar DG | Asus PA248Q
#9ajko000(Topic Creator)Posted 8/29/2014 4:44:54 PM
WerdnAndreW posted...
ajko000 posted...
http://i.imgur.com/WTk82HI.png

Now, do I want to check that? I'm on Windows 7. I ask because I hit, "Uninstall" but then it gives me that. Does that mean it will uninstall the drivers from my device as well as my computer? Or just my computer?


Yes, check the box. When you plugged it back in, did it say it was installing drivers?


It did. But my headset is not showing up, neither the mic or the headphones.
---
I have OCD, so I close all my topics once I'm done with them.
#10ajko000(Topic Creator)Posted 8/29/2014 4:53:01 PM
My headset is the Corsair Vengeance 1500 btw.
---
I have OCD, so I close all my topics once I'm done with them.