Compatible with vista?

  • Topic Archived
8 years ago#1
I just installed my copy of the game last night on my vista, it ran perfectly fine. But today when i tried to play it again, a window pops out and tells me a problem has caused the program to stop working normally.

After that, i went into the directory and found the file and clicked it, it ran perfectly again, and now, it gives me the same msg.

i tried reinstalling, i tried reformatting my comp, made no difference. Any solution to the problem?

and i was so looking forward to play it :( :( :(
8 years ago#2

I have the same problem when runnig the game on vista..

just keep trying to run it, over and over again.. it works for me..

8 years ago#3
Same problem here. I'd like to get a few more minutes of playtime than a few minutes at a time, if you know what I mean.

Help me Yoda!
"There is truly nothing funnier in life then using your Z key to roll a dead grizzly down a big hill, try it some time." - damogamo
8 years ago#4
From what I've seen with other topics, TSL only works with Vista if you're lucky. After a bit of searching, I found a 'fix' on Obsidian's official forums:
1. Install KOTOR2 from the CD (You do not need to run it in compatibility mode).
2. Update to the latest version - this will cause the "Invalid Disk" error.
3. In order to solve this error, you will need to go to the SecuROM support page ( and follow the instructions there. They will respond and send you a new exe file which will fix this.
4. You will (on occasion) encounter the "Knights of the Old Republic II: The Sith Lords has stopped working" error. This is due to a file conflict issue.
5. In the KOTOR2 root directory (e.g. C:\Program Files\Lucasarts\SWKOTOR2) there will be the file "Mss32.dll". You will need to replace this file with the one from the KOTOR1 directory (If you don't have it, try or
6. Start playing ...

But like I said, it mostly seems to come down to luck.
A clever little bleeder, was Oscar Wilde. He once defined a cynic as a man who knows the price of everything and the value of nothing. Call me a cynic, then.
8 years ago#5
I just downloaded the Mss32.dll from kotor 1 and set kotor 2 to windows 98 capatiblity mode. The games runs perfectly, minus the glitches (which has nothing to do with vista mind you.)
Anti Harken Fanboy since May 2001.
8 years ago#6
I'm getting that "stopped working" error too, every time I try to open it. Just finished installing it. I'll try copying the one from KotOR I, and see if that works.

I hate Vista.
8 years ago#7
When I try to follow the instructions on that SecuROM page, they don't work. There's no "launch analysis" when I right-click anything but the disc itself, and I can't find the file it generates to send to them.

Did I do something wrong?
8 years ago#8;85439x#1443935

Here's the patch, just download it and drag it into the main directory, not override. It will ask if you want to overwrite the existing file, do so - though make a copy of it (just in case) beforehand. It has worked for me so I hope it can do the same for you.
Happy gaming! :)
This world is made of...
Love and Peace! ~ Vash
8 years ago#9
Thanks for the help guys! :D
8 years ago#10
I have tried replacing the "Mss32.dll" file (sp?) but I had no success. I also tried using XP sp2 compatibility mode, which also didn't work.

I have patched the game to the latest version (Whatever is on LucasArts page). I then opened the config from the launcher menu and lowered everything to the lowest settings with sound still enabled...thats the only way I can start the game up. Without XP mode enabled.

Once I get to the menu I can raise the graphics to full. I am using a Dell Latitude D530 with Vista Business.
I think therefor I am.....I think

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived