All DLC is unauthorized?

#1DuarianPosted 4/9/2011 11:56:45 PM
I have read that some people have been having trouble with this but everyone seems to have solved the problem. I recently popped this in to play again and all of my once working DLC (I have ultimate edition) is not working, no matter how many times I disconnect and re-connect it keeps saying the same thing. I even tried uninstalling and re-installing the game. Yes the game is registered on my account so thats not the problem..are the servers having issues or something or is there a fix I am missing? Thanks!
---
Core I7 920 | Gigabyte EX58-UD3R | 6 GB DDR3 | 2 x 500 GB HDD | SB X-fi Titanium Pro Fatal1ty | EVGA GTX 570 HD | Antec 650W | G15v2 | G9 | Hanns G 28"
#2ilikeMUSICalotPosted 4/10/2011 12:19:45 AM
I just bought the game and I am having the same problem. I have tried everything and it still doesn't work. If anyone can help, it would be much appreciated.
#3V1zdr1xPosted 4/10/2011 12:32:09 AM
http://social.bioware.com/forum/1/topic/58/index/416923/5

A few posts down (it's a quote in Crucialus 's post) it gives a solution. I didn't read all of it but from what I gathered there's a problem with bioware's server. You can do this solution and try to see if that works. There are some people saying that their items in their games go missing if they try to do this so the choice is yours.
#4some09guy IIPosted 4/10/2011 2:53:23 AM
Before you try anything, go to the Configure application which comes with the game. Along the left side you'll see a number of tabs. Click 'Game' and under the Product Keys section make sure that your product key is saved correctly.

I had the same problem recently and this ended up being the issue. For whatever reason the game hadn't saved the product key at all so everything was unauthorized. If not, go into the addins.xml in the Documents/Bioware/Dragon Age/Settings and change your DLC from Requires Authorization=1 to Requires Authorization=0.

But yeah, the servers are s*** by now and are going largely ignored. Hell, I don't even think character profiles update anymore. Apparently Bioware was under the impression everyone'd drop Orgins the second DA2 was released.
#5RentedToolboxPosted 4/10/2011 6:18:23 AM
Play in offline mode. If you cut EA out of the equation entirely the game works fine, unsurprisingly.
#6bcarlPosted 4/10/2011 8:48:54 AM(edited)
Last night I used the solution some09guy posted and it worked perfectly. This is where that's from: http://support.ea.com/app/answers/detail/a_id/218/showhome/true

---
#7Duarian(Topic Creator)Posted 4/10/2011 10:51:49 AM
amazing how Bioware sent me about 10 things to do and none of them worked, yet what was posted on here worked perfectly, thank you very much for posting that!!!
---
Core I7 920 | Gigabyte EX58-UD3R | 6 GB DDR3 | 2 x 500 GB HDD | SB X-fi Titanium Pro Fatal1ty | EVGA GTX 570 HD | Antec 650W | G15v2 | G9 | Hanns G 28"
#8Menace2SocietyPosted 4/10/2011 11:02:54 AM
bcarl posted...
Last night I used the solution some09guy posted and it worked perfectly. This is where that's from: http://support.ea.com/app/answers/detail/a_id/218/showhome/true

---


the fix works for me when playing the origins campaign but every time i try one of the other dlc campaigns it gives me a "fail to load module" error. Bioware/EA are a joke. its already bad enough i have to deal with all the crashes and memory leaks but now in attempt to hurry and beat the DLC's before the far superior witcher 2 comes out i can't even access them. nice going bioware, until i am able to complete all the dlc's i won't be buying DA2 and even then it it won't be until ultimate edition of DA2 comes out at a heavily discounted price...

bring on Witcher 2!!!!
#9bcarlPosted 4/10/2011 11:10:21 AM(edited)
As far as character updates go, DA2 characters and achievements have been turned off in 'Recent Activity' on BSN, as well as the 'Search' function until the initial flurry of activity is over. Your DA2 characters and Achievements are still being updated, though. New Origins chars and updates are still in 'Recent Activity' as they haven't been disabled.

To the poster above...I started a brand new Witch Hunt after I went through the Addins.xml. I found, however, I didn't fix it the first time going through that file as it has over 20,000 lines with all my mods...lol. Had to do a 'search' for it, changed it, then started the game with no problem. Are you sure you still have no 'unathorized'?

---
#10LeBurns63Posted 4/10/2011 12:00:48 PM
Just logging off worked for me, though I'm not sure what that does as far as achievements go. I plan on getting the Reaver class unlocked this playthrough and I think you have to be logged in for that to keep.

I just hope they fix this thing soon.
---
Cat Head Biscuits and Apple Butter - YUM!