Got this on steam, using windows 7. Game will not load.

#1GoldenHawk777Posted 12/31/2009 11:47:24 PM
When I try to start Bioshock, I get the little emblem in the middle of the screen then a few seconds later the windows error box pops up, saying that bioshock.exe has stopped working. Is there a way to fix this?
---
Q9450 2.67ghz, 8800GT, 4GB OCZ RAM 800mhz, 650watt Cooler master Power supply, 1.25 Terabyte storage, 780i mobo, Antec 900 case. 1680X1050
#2Mechwarrior 02Posted 1/1/2010 3:35:36 PM
I had problems on startup problems (windows 7 also), these 2 things did the trick for me

Validate the files under steam
Run in windowed mode
---
PSN: Arcjo :::::::::::::::::: Gamefaqs Ancient: 11/29/08
Stomping goombas, kicking turtle shells, and eating mushrooms since 1984
#3ricster2000Posted 1/3/2010 4:33:03 PM
I had the exact same problem last week, turns out the fix was to enable stereo mixing (which is disabled by default with realtek audio)

Control Panel --> Sound --> Recording --> Right Click blank area and Show Disabled Devices --> Enable Stereo Mix

Hope this helps.

---
"Your Lord and Master, Foamy" - Foamy
#4GoldenHawk777(Topic Creator)Posted 1/4/2010 12:43:31 AM
Its still not working. It still pops up with the bioshock icon in the middle of the screen, in a small box (desktop still visible) and then "bioshock.exe has failed"
---
Q9450 2.67ghz, 8800GT, 4GB OCZ RAM 800mhz, 650watt Cooler master Power supply, 1.25 Terabyte storage, 780i mobo, Antec 900 case. 1680X1050
#5OpenThePeoplePosted 1/11/2010 6:15:14 PM
I'm having the exact same problem. I've also noticed that the game starts up fine when I'm at my friend's place on his internet, but it doesn't work in offline mode. I can't seem to figure out what's going on either. Come on 2K...
#6bond617Posted 1/11/2010 9:29:21 PM
i had the same problem(win7 x64 ultimate w/ a gtx 260), but it disappeared after going to microsoft's website and updating directx11 to the newest release.
---
The FF4 Reference Book:
http://rb.thundaga.com
#7zLeedPosted 1/17/2010 10:11:25 PM
I have win7 ultimate and I don't have any problems. Must be something you have on your computer or something. Have you checked your firewall (settings)?
---
Favorite games: Tf2; Mother 1,2,3; COD4; SSBB; FF4.
Number of times zLeed has been last to post : more than SSBB threads
#8RezkehPosted 1/22/2010 6:42:09 PM
I had this problem. I solved it today though.

(Before I begin this long post, please make sure your DirectX is up to date)

After scouring the internet for a day, I found out that many people had experienced difficulties with the game. I will try to help you out as best I can. Try:

Validating game files. It you get a 100% positive, try to launch the game. Are you still getting an error?

If yes, then right click on BioShock in My games, then click Properties. Click Set launch options..., then type "-nosound" (without the quotation marks).

Try to launch the game. A number of things could happen here, either your game hangs at a black screen, or you get into the game but from the plane crash onwards you have absolutely no in-game sound.

------------------------------------------------------------------------------

If you get a black screen (or any kind of immediate crash) - browse to your Default.ini file (.../BioShock/Builds/Release) and do the following (I suggest you make a backup of this file before you change anything):

Edit your default.ini. Put a semi-colon in front of AudioDevice=FMODAudio.FMODAudioSubsystem, and add the following line right after it:
AudioDevice=D3DDrv.D3DAudioDevice

After edits, that part of the config file should look like this:

;AudioDevice=FMODAudio.FMODAudioSubsystem
AudioDevice=D3DDrv.D3DAudioDevice


------------------------------------------------------------------------------

Try to relaunch the game. You should no longer be getting startup crashes. If you are, try clean installing steam - http://developer.valvesoftware.com/wiki/Cleanly_reinstalling_Steam -, and try again. If you still experience a crash, delete BioShock's local content and try a re-install.

------------------------------------------------------------------------------

By this point you should be able to access the game. However, it is incredibly likely that you will have no sound when you actually play.

I will make this note clear now: If you can hear a piano key noise when you press any option in the main menu (such as "Continue", "Options", etc) then the in-game sound will work. If you can't then be prepared for more tweaking.

------------------------------------------------------------------------------

Now, if you are using a Realtek soundcard, then read this (taken from 2K forums): Again, ensure the drivers are up to date.

In some cases you may encounter stuttering sound or no sound at all when playing Bioshock with a combination of Windows Vista/7 and Realtek onboard sound. To ensure the best possible sound performance from your system when playing Bioshock, please follow the steps below:

- Ensure you are running the latest Realtek drivers, these can be downloaded from Realtek directly via Realtek. Alternatively your motherboard manufacturer will also be able to provide up to date drivers.

Note: If you are encountering any other issues with your sound or if you are in doubt as to what software you need then please contact your motherboard manufacturer prior to installing any driver software.

- Enable Stereo mixing, to do this browse to Start > Control Panel > Sound (in classic view). Once done switch to the Recording tab which will show the currently active inputs on your system (e.g. Line in, Microphone). Right click in the clear space below these devices and select the option for Show disabled devices. This should show an additional device called Stereo mixing, right click on this device and select Enable.

------------------------------------------------------------------------------

Going on to second post. I hope it is worth it...
#9RezkehPosted 1/22/2010 6:55:35 PM
Now, if you (like me) are not using a Realtek Soundcard, and you have no option of enabling stereo mixing, then carry on and try these procedures.

------------------------------------------------------------------------------

Select your BioShock desktop icon, and right click. Go to Properties, then in the "Target:" box, (should already have something along the lines of -> "C:\Program Files\Steam\Steam.exe" -applaunch 7670 <- in it) and add -dx9 to the end. It should look like this:

"C:\Program Files\Steam\Steam.exe" -applaunch 7670 -dx9

Before you run the game, remove the -nosound from within the Steam platform. Hopefully, you should still be able to get into the game. If the sound works, hurrah! If not, read on.

------------------------------------------------------------------------------

Now go to Options, followed by Audio. I've seen people report success by fiddling in here, so I will list them for you to try if you wish.

- Disable both Reverb & Creative EAX. This alone could solve the problem.
- Change the audio type at the top to Pro Logic. It didn't work for me, but for someone it did.

On the subject of audio, if you have Creative AL installed on your computer, some people have reported success uninstalling that via Control Panel and then trying the game again.

------------------------------------------------------------------------------

Running out of ways to fix the issue now.

However, this point is what fixed it for me.

Make a new Steam shortcut on your desktop. Right click, Properties. Click the Compatibility tab, and choose Windows 2000 (you may also want to experiment with Windows XP SP2, Windows XP SP3). Launch Steam, and then try to run BioShock through Steam via My games with no shortcut tweaks (So get rid of -dx9 and -nosound if you haven't already).

Hopefully, that should fix it for you. If not, then I'm afraid I can't really offer any more help.

Good luck!
#10VolucerPosted 2/10/2010 12:58:03 PM
Ah, tried everything suggested and nothing's managed to fix it. Was working fine a month ago, and now for some reason it's not.
---
Gamertag: Volucer
Pronounced: Vol-oo-sh-er