How to fix BioShock for Windows 7 (steam version)

#1AnonysaurusRexPosted 11/3/2010 2:47:18 PM
http://forums.steampowered.com/forums/showthread.php?t=1133842

This is a step-by-step process that takes you through what your problem(s) may be. It helped me find out that BioShock wouldn't run due to OpenAL being installed by my soundcard.

If you can run the game with "-nosound" as a launch setting, then clearly your problem is the soundcard. If not, try "-dx9"

If none of the above work, stop reading this topic and click on the link and read that guy's topic.
---
http://imgs.xkcd.com/comics/python.png http://img215.imageshack.us/img215/9277/anonysauruss.png
#2ShurikoPosted 11/6/2010 9:21:40 PM
I just went into sound options and enabled the device "Stereo Mix" in recording and it made my sound work.
---
http://i56.tinypic.com/30c64b9.gif http://i29.tinypic.com/2vcx24k.gif
On a magical DERP, I fly awaaaay into the rainbows
#3AnonysaurusRex(Topic Creator)Posted 11/6/2010 10:23:02 PM
I don't have a Realtek or whatever it is card, so I don't have a Stereo Mix option
---
http://imgs.xkcd.com/comics/python.png http://img215.imageshack.us/img215/9277/anonysauruss.png