question about win 7 64 bit compatability

  • Topic Archived
  1. Boards
  2. Age of Empires III
  3. question about win 7 64 bit compatability
5 years ago#1
Hey thanks for taking the time to read this. so ive tried all the choices it gives for the win7 64 bit compatibility, and every time i try to load the game it does load.. but theres no picture, i get the sound but theres just no image.

I read the FAQ but i didnt find anything in there relating to my problem. I used to play AoE 1 and 2 but started to play other games, now ive come back to AoE and wand to play this one, my specs are: Intel core 2 quad,processor Q6600 @ 2.40 GHz, 3.0 GB ram, win7 64 bit, 650gb hard drive, Nvidia 8800GT vid card,

i know my PC can run the game, and ive updated the drivers. Its just something to do with the image thats not coming though which i havent figured out yet. So any suggestions would be greatly appreciated.
5 years ago#2
Just Age of Empires 3, no expansion packs
5 years ago#3
Try installing the patch, it fixed all my problems.
http://agecommunity.com/gameUpdates.aspx


---

We watch. And we are always there.
5 years ago#4
i too just got win 7 and i was going to install this game but it says there are known issues with it. wil the game patches fix this? i have win7 32 bit btw.
5 years ago#5
I run this game on windows on my macbook. It definately works on windows 7.

If you have the correct drivers, you should be able to see the game; try updating them. I had a similar problem- but had to install the drivers off the CD that came with the computer again.
---
HG FC: 0346-2152-8657
5 years ago#6
Yea I run it at max settings with infinite population mods and it runs perfect.
After using the patch I posted above I use these settings to run:
-Run in compatibility mode for XP service Pack 2
-Disabled visual themes
-Disable desktop composition
-Run as administrator

My Specs:
Win 7 x64
AMD Phenom II X4 810 2.6GHz
4 gigs DDR3
ATI Radeon HD 4850 PCI-E 16X 1GB

MOTHERBOARD:
Asus M4A77TD PRO AM3 DDR3 AMD 770 Chipset CrossFireX Technology
SATA RAID MB w/GbLAN,USB2.0, &7.1Audio



---

We watch. And we are always there.
5 years ago#7
Hey guys, I too am running win 7, but my question is that I have Warchiefs as well as regular game. Should I install patch before installing Warcheifs or after installing Warcheifs??
---
Lag is like the force in star wars, it's people's excuse for everything.
5 years ago#8
I patched it before installing The Warchiefs and it runs great with the specs I listed above.


---

We watch. And we are always there.
5 years ago#9
Alright thanks a ton man.
---
Lag is like the force in star wars, it's people's excuse for everything.
  1. Boards
  2. Age of Empires III
  3. question about win 7 64 bit compatability

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived