360 compatibility

#1UbdUPosted 10/12/2008 2:32:34 PM
I see that the original is compatible, but Ties that Bind is not on the compatibility list. Has anyone confirmed this?

I'm looking to get this, and I'd rather play it on my 360 than on my PS2.
#2greedycrispPosted 10/15/2008 5:11:42 AM
I verified that Ties That Bind is not compatible as of today's update. The original Suffering does boot up.