This is a split board - You can return to the Split List for other boards.

problem with my power supply...

#1MetroidHunter13Posted 10/20/2011 9:19:24 AM
i have one of the arcade models with the internal memory card (has the jasper chipset) and lately, over the past week, my power supply has made this... chugging whirring noise.

last night while i was playing castlevania, the whole xbox shut down, and the light on the power brick turned red.

i unplugged it, and let it sit for a few minutes and plugged it back in. xbox turned on just fine, i shut it off and went to bed.

getting ready to leave this morning, i turned it on to check it again, and it works fine.

last night when i unplugged it to let it sit, i smelled it, and it smelled like burning plastic, im not sure what i can do, or if anyone else has had this problem, or have heard about it.

can anyone shed some insight? i was thinking of taking a can of compressed air and trying to clean it out, maybe some dust or hair or something is clogging the motor for the fan or something.
---
R.I.P. Jimmy "The Rev" Sullivan, you'll be missed.
Xbox Live GT - Disp0sable13 --- http://i48.tinypic.com/2r2ri13.jpg
#2MetroidHunter13(Topic Creator)Posted 10/20/2011 11:03:09 AM
bump
---
R.I.P. Jimmy "The Rev" Sullivan, you'll be missed.
Xbox Live GT - Disp0sable13 --- http://i48.tinypic.com/2r2ri13.jpg
#3ZashulePosted 10/20/2011 12:21:59 PM
http://www.amazon.com/AC-Power-Supply-Microsoft-XBOX-360/dp/B000PT18OS/ref=sr_1_1?ie=UTF8&qid=1319138498&sr=8-1
---
http://backloggery.com/Zashule : Last 1000 Sonic & SEGA Racing : Last 200 Super Monkey Ball (WP7)
Current XBOX LIVE GS: 71,550 Next Goal: 80,000 GT: TBreit