This is a split board - You can return to the Split List for other boards.

Game shoes up in XMB but when I start it, I get a blank screen.

  • Topic Archived
  1. Boards
  2. PlayStation 3
  3. Game shoes up in XMB but when I start it, I get a blank screen.
2 years ago#1
Anyone else had this problem?

Im trying to run an older game that I haven't played in a while, Skate 2 and even though the disk is detected by the ps3 and it plays the hover over video and sound but when I start the game, all I see is a blank screen. It's been like that for 10 minutes now.

Is it something wrong with ps3 or with the disk? I tried it on 2 ps3's so it can't be the ps3 can it? Some bad firmware changes maybe?
---
Sketch Blog - paperuni.blogspot.com
2 years ago#2
I've never had shoes on the XMB.
---
I am Mogar, God of Irony and The Devourer of Topics.
http://i.imgur.com/gcqrYXl.jpg
2 years ago#3
Shows. SHOWS. SHOWS!!!!!!!
---
Sketch Blog - paperuni.blogspot.com
2 years ago#4
leon_trunks posted...
Shoes. SHOES,. SHOES!!!!!!!


Ok we get it, just stop.


Lol jk, Your disc laser might be close to dying.
---
PSn:arclouksx/JustArc_ -Now playing: Persona 3 Portable,The Walking Dead,MGS 3 HD.
http://rebelallianceclan.com/signatures/RAarclouksx.png
2 years ago#5
Clean the disc with a microfibre cloth, even if you can't see any smudges.
---
Meet the new love of my life--
http://itotd.com/view/80/
2 years ago#6
might be the laser or you might have to restore the file system
  1. Boards
  2. PlayStation 3
  3. Game shoes up in XMB but when I start it, I get a blank screen.

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived