Attention Owners of AMD/ATI Graphics Cards:

#1Who knowsPosted 5/7/2012 5:26:17 PM(edited)
If you're using drivers 12.4, which are the latest, they will not work with Diablo 3.

http://us.battle.net/d3/en/forum/topic/4835923564

Edit: Its only particular cards, check to see if you're affected
---
I once knew, but now I no know, so who knew who knows?
Times people have replied to my topics with Who Knows? 51
#2taketheshoeoffPosted 5/7/2012 5:01:54 PM
heh suckers..

just buy nvidia
---
[This message was deleted at the request of a schizoid or closet case]
#3configmePosted 5/7/2012 5:03:25 PM
http://www.pcper.com/news/General-Tech/Ready-Diablo-III-Not-Catalyst-124-youre-not

"UPDATE 2:22pm: An AMD representative has informed us that that bug referred to by the Blizzard forum support person in fact ONLY affects Radeon HD 2000, 3000 and 4000 users. The 12.4 Catalyst software will work fine with 5000, 6000 and the new 7000 series of graphics cards apparently. "
#4importflipPosted 5/7/2012 5:03:52 PM
And that is why I left AMD/ATI cards behind. Their driver support has been terrible in the 12.X generation of drivers.
---
|| Intel i7 2600k (4.8GHz) || TR Silver Arrow || AsRock Z68 Pro || GS Ripjaws X 1866 (2x4GB) || EVGA 680 SC || Corsair 650D ||
#5RoughNTumblePosted 5/7/2012 5:06:29 PM
doesn't affect my amd card
---
Grandparents dead - please no jokes
Make mine DC, if you please.
#6kingdrake2Posted 5/7/2012 5:11:24 PM
RoughNTumble posted...
doesn't affect my amd card

this. mines a 6000 series.
---
They literally gave him the keys to the kingdom and he pissed it all away--dragonballer88
#7PsyborgasmPosted 5/7/2012 5:13:55 PM
Who knows posted...
If you're using drivers 12.4, which are the latest, they will not work with Diablo 3.

http://us.battle.net/d3/en/forum/topic/4835923564


Nice try!
#8TheGlowPosted 5/7/2012 5:13:58 PM
taketheshoeoff posted...
heh suckers..

just buy nvidia


I'm checking for best bang for buck vid cards, and always ATI pops up.
Hence I still use my 260 gtx.
#9scph9002sterPosted 5/7/2012 5:15:57 PM
This does not affect 5000 series card and up, only older amd cards.
---
2500k @ 4.5ghz | Asus 7970 @ 1125/1575 | 8gb Ripjawsx @ 2133 cl9 | P8Z68 V Pro/Gen3 | Vertex 3 120gb max iops ed ssd
#10DeathHopePosted 5/7/2012 5:16:16 PM
That bloke discovered the issue when trying out the beta, right? So does that means if I own a AMD card yet can play the Beta with no issues, i'll be fine?
---
PSN ID: EternalWrath