Choppy frame rate

  • Topic Archived
  1. Boards
  2. Diablo III
  3. Choppy frame rate
3 years ago#11
Sympathy helps a little I suppose..!

It's so weird. Last night I got the vsync to hold it with a max
Of 60 FPS and played for a good 3 hours with no problems.
Took a break for dinner, and when I came back I couldn't for the life of me get it to lock at 60 with vsync on. It locks at 50 everytime unless I disable the max FPS at which point it jumps around sporadically and flutters nonstop.

Bah

Haaaaeeeeeelllllpppppppp
3 years ago#12
Also having problems, with a 570
60 locked day one
Then dipping yesterday followed by 20 frame max after maintenance
With beta 301
---
GO NOLES!
3 years ago#13
Starrman4 posted...
Snag the beta drivers version 301.something and see if that helps

What's this beta 301 stuff? Is that an nvidia beta driver or something?

Not home so I can't really research but I'm trying to get info while I'm at work so I have a plan of attack when I do get home wanting to play!
3 years ago#14
I have a GTX 465 which has been running the game smooth on max. I only notice it being really choppy when I first start the game, sometimes when it shows something 'new'. After that, perfectly smooth.

I've also played a little on a laptop, but it's a Radeon 6000M series (don't remember the specific model number). It has behaved the same with the game, graphics settings are all on default with it.
3 years ago#15
well this is a very common problem as it turns out. a quick perusal of the battle.net forum shows it. I've posted my problems on the second thread of people discussing the problem. (My S/N is Rotwang if you're curious.)
11 pages long on the second thread. Another one on there with 269 replies. Seems to be a major problem on Blizzard's end.

Link:
http://us.battle.net/d3/en/forum/topic/5152405749?page=11
3 years ago#16
qwertyuopasdfgh posted...
Hi guys,

I have a gtx 560, 8 GB of ram and an i5-2500 @ 3.3 GHZ. However this game runs extremely slow and choppy as soon as any enemies appear on screen. I played the beta with no problems though. I lowered all the settings to the lowest and still had this problem. Any advice? Thanks very much.


I have same setup except I have an i7. Smooth as silk with everything full, my older card which i just replaced on launch day because it fried 5 mins into just installing and playing diablo 3 ran it at full and it was a gts 240 which is a lot slower then a 560.

So this has nothing at all to do with the game. I think
(edited 0 seconds ago)
3 years ago#17
It's probably game issues with the drivers. If you have the latests, try the beta version. If that doesn't work, try installing previous versions.

Today morning I had an issue where it was all jumpy FPS wise but it got alright after a bit.
3 years ago#18
bob15x posted...
qwertyuopasdfgh posted...
Hi guys,

I have a gtx 560, 8 GB of ram and an i5-2500 @ 3.3 GHZ. However this game runs extremely slow and choppy as soon as any enemies appear on screen. I played the beta with no problems though. I lowered all the settings to the lowest and still had this problem. Any advice? Thanks very much.

I have same setup except I have an i7. Smooth as silk with everything full, my older card which i just replaced on launch day because it fried 5 mins into just installing and playing diablo 3 ran it at full and it was a gts 240 which is a lot slower then a 560.

So this has nothing at all to do with the game. I think


It has everything to do with the game, I'm afraid. Follow my link above if you don't believe me.
Mine runs smooth as silk sometimes for hours on end and will lock at 60 FPS where I want it.
But when I log in an hour later, it jumps from 60-120 so fast I can't even read all the numbers and stutters like crazy.
If I enable VSYNC it locks at 50 and stutters. Sometimes if I mess with it enough it will go back to 60 but it's getting harder and harder.
Can't be the cpu. I have nothing else running. It's a problem many many people with beast machines are having.

It's a Blizzard problem. They're staying pretty quiet about it right now but judging from their forums there are hundreds if not thousands of users harassing them about it. So I'd expect they are looking into it. (or at least hope. the frustrating thing is they aren't responding in the threads right now)
3 years ago#19
twohats_fisher posted...
bob15x posted...
qwertyuopasdfgh posted...
Hi guys,

I have a gtx 560, 8 GB of ram and an i5-2500 @ 3.3 GHZ. However this game runs extremely slow and choppy as soon as any enemies appear on screen. I played the beta with no problems though. I lowered all the settings to the lowest and still had this problem. Any advice? Thanks very much.

I have same setup except I have an i7. Smooth as silk with everything full, my older card which i just replaced on launch day because it fried 5 mins into just installing and playing diablo 3 ran it at full and it was a gts 240 which is a lot slower then a 560.

So this has nothing at all to do with the game. I think

It has everything to do with the game, I'm afraid. Follow my link above if you don't believe me.
Mine runs smooth as silk sometimes for hours on end and will lock at 60 FPS where I want it.
But when I log in an hour later, it jumps from 60-120 so fast I can't even read all the numbers and stutters like crazy.
If I enable VSYNC it locks at 50 and stutters. Sometimes if I mess with it enough it will go back to 60 but it's getting harder and harder.
Can't be the cpu. I have nothing else running. It's a problem many many people with beast machines are having.

It's a Blizzard problem. They're staying pretty quiet about it right now but judging from their forums there are hundreds if not thousands of users harassing them about it. So I'd expect they are looking into it. (or at least hope. the frustrating thing is they aren't responding in the threads right now)


Interesting. usually when I see the problems relate to a specific brand of cards usually the drivers are to blame. Guess I am lucky, I played about 8 hours so far and no change at all in frame rate.
3 years ago#20
I'll try the beta driver whenever I get home and see if that helps. I just hope this is fixed quick because it's pretty unfortunate.
---
PSN: amg123 GT: skilletbun
  1. Boards
  2. Diablo III
  3. Choppy frame rate

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived