Windows 7??

#1keystone1221Posted 11/6/2009 12:20:42 PM
Will these games work on Windows 7?
---
Savvy?
#2___Sniper_28_Posted 11/9/2009 11:05:14 AM
I heard the most expensive version of windows 7 has the ability to run programs meant for like windows 98 and xp or something like that...

but in time they definitely will, i would still think there are people who are willing to make patches to the games to make them work for windows 7.
---
the master
#3FL81Posted 12/2/2009 8:54:54 AM
[This message was deleted at the request of the original poster]
#4FL81Posted 12/18/2009 4:14:26 PM
[This message was deleted at the request of the original poster]
#5zerocoalPosted 12/26/2009 7:20:38 AM
I'm on Windows 7 and right after installation C&C and Generals worked. After playing generals for awhile tiberium sun and RA2 started to work.
---
"lol a topic called "Why is it rated M?" is on the same page as a topic called "CANNIBAL BABIES!!!" ~ hion75
#6iceman2214Posted 1/25/2010 6:01:57 AM
I installed the all games on Win 7 64 bit, so far only tried C&C (1995) and this runs perfectly (does have borders though!)
---
"I'd rather have it and not need it, than need it and not have it"
#7zerocoalPosted 1/30/2010 5:00:05 PM
After further exploration into my game, the only things that work on my laptop now are Generals, tiberium sun, and the original C&C. Red alert 2 tries to start and then just reopens the first decade launcher.

At least I have the contra mod for my generals though.
---
"lol a topic called "Why is it rated M?" is on the same page as a topic called "CANNIBAL BABIES!!!" ~ hion75
#8FL81Posted 2/10/2010 4:27:00 PM
I got a computer with Windows 7 Home Premium 64 bit recently, and all of the games seem to work fine for me.
---
http://img40.imageshack.us/img40/2655/fl81.png
#9DarkGidoraPosted 3/6/2010 7:28:39 PM
I recently got a laptop running Windows 7, and most of the games work fine for me, minus some weird glitches (the colors in RA are screwed up). For some reason, however, whenever I try to apply the two official patches, I get a message telling me to run the application as Administrator, even though the account I'm trying to run them on has administrator status. The unofficial patch works fine.
---
I once told someone that I knew 34 ways to kill a person with my bare hands. He said I was a liar. I told him to pick a number.
#10ComduterPosted 4/1/2010 8:56:36 AM

I recently installed it on Win 7 Pro 32 bit, and it runs pretty lousy. The colors in RA1 are completely screwed up (all shadows have bright teal tint). RA2 and Generals won't even run at all. All of this still happens after installing the unnoficial patch. I'm not the least bit surprised that Ea didn't bother to update this collection for proper Win 7 support. How are you people able to get this thing to run properly? The patches do nothing.