NCsoft Launcher

#1kyle3416Posted 7/31/2009 6:49:03 AM
so I'm having some issues with the NCsoft Launcher- any help is greatly appreciated!

I pre-purchased Aion yesterday to try out the beta today. Everything goes fine up until the point when it completes installing the 356kb installer. At that point it installs the NCsoft Launcher to open and install your game. Problem is when I click on the NCsoft Launcher it simply will not open, at all. No error message, nothing, it just doesn't open, nothing happens. I have no firewalls/antivirus running and have tried reinstalling it like 10 times. Anyone experiencing this issue also? I tried the beta forums but I can't login, I also sent a ticket early yesterday to NCSoft but have no heard back. Thanks!
#2SirGizmoPosted 7/31/2009 7:02:32 AM
Stupid question, but you're running it as admin (for vista)?
---
Belgarath - Leader of Grievance - Aion
www.grievancelegion.org
#3kyle3416(Topic Creator)Posted 7/31/2009 7:16:52 AM
Yeah I am running on admin.

Actually i just looked into the log reports and there IS a log as to why it was not opening (or I guess crashing without any sign of it). It notes something about Veranda font being out of date for vista... Anyone know where I would be able to download updated Veranda font?
#4kyle3416(Topic Creator)Posted 7/31/2009 7:56:50 AM
So yeah... It looks like the fonts were the issue. Apparently the Verdana and Arial fonts that I had did not work so I had to have my friend send me ones and overwrite them. Strange, but it works now at least! Now I get to wait 9 more hours while it installs bleh
#5Lycan_666Posted 8/1/2009 10:24:52 PM
can u please send links and what to do, this is driving me crazy
#6ashphoenix77Posted 8/2/2009 5:30:33 AM
9 hours?!?! your lucky! im on day THREE! lol at 96% though woohoo

---
PSN name : augustheat77
add and ill accept
#7spymasta5Posted 8/2/2009 3:18:31 PM
kyle3416 posted...
So yeah... It looks like the fonts were the issue. Apparently the Verdana and Arial fonts that I had did not work so I had to have my friend send me ones and overwrite them. Strange, but it works now at least! Now I get to wait 9 more hours while it installs bleh



DUDE you gotta send me or post what you did to fix it cuz i'm going crazy trying to figure this out.