Crashing almost right after launching the game?

#1ShadowsRunnerPosted 3/18/2010 9:28:16 PM

I just bought Metro 2033 and was extremely excited after downloading it from Steam. So I launched the game successfully on steam for the first time and did some video settings tweaks and did a restart as prompted.

Right after that I launched the game again, ready to experience metro 2033, and then it freaking freezes on me and said metro 2033 executable has stopped working even before getting to the menu.

Is anyone getting this issue? I'm trying to re download the game again. I also tried launching the game in safe mode as prompted but no dice. Please help I want to enjoy this game...

#2jh32uk2Posted 3/18/2010 9:31:50 PM
There is many reasons and many fixes (on the Steam Forums)

The most common is you have Dual Monitors, disable the secondary and it will run.
#3FullDragon1Posted 3/18/2010 9:41:41 PM
[This message was deleted at the request of the original poster]
#4Fallen_LordPosted 3/18/2010 9:44:37 PM
Everytime I launch the game I get a box telling me to update my drivers, the ones I am using might make the game unstable. Try updating your video drivers if you haven't already.
---
http://bf2s.com/player/44664753/
#5FullDragon1Posted 3/18/2010 9:45:31 PM
If it is Windows 7 64 Bit

C:\Program Files (x86)\THQ\Metro 2033

try deleting file

content.upk0
#6FullDragon1Posted 3/18/2010 9:50:33 PM
It freezes for me when I press start before menu and I press Control-Alt-Delete to bring me back to desktop then press the Icon again to start again and it works.

I suck at this sorry if I don't help
#7ShadowsRunner(Topic Creator)Posted 3/18/2010 11:15:11 PM

FullDragon1 posted...
If it is Windows 7 64 Bit

C:Program Files (x86)THQMetro 2033

try deleting file

content.upk0


Tried that and no go. I just re download and still no go. Verified my game content and still no dice. What the heck is this s***

#8FullDragon1Posted 3/18/2010 11:41:54 PM
Try this website to identify your problem and find a fix

http://www.gamebrood.com/2010/03/18/metro-2033-pc-crash-black-screen-freezes-executable-has-stopped-working-audio-glitches-cant-launch-and-more-fix-and-fixes/
#9ShadowsRunner(Topic Creator)Posted 3/19/2010 3:02:46 AM

I fixed it. Apparently something would go really wrong if I choose the game to run on direct X 10 so I can only play on direct X9 right now. Strange. Changing back to DX9 fixed the problem.

#10Pecone_PenevPosted 3/19/2010 5:46:18 PM

Have you guys installed the PhysX drivers that come with the game? I had the same problem until installed the PhysX. Give it a try if you haven't done so.