Downloading Client?

#1RethalwolfPosted 7/18/2012 11:51:16 AM
Hey guys idk if this is a common problem or not but I'm rolling Windows 7 and every time I try to download the client, a window pops up with a pang that says the installer isn't compatible. I got this several times last week until I used Chrome for the download and it went through, but I think they changed the client and since then I haven't been able to open it.
It also says there could be an error with where I'm downloading it from and I should redownload from the original place, which I have, several times.
Has anyone else had this problem and is there a good fix?
I have 350 gb of memory left so...
---
"The point of war is not to die for your country. It's to make the enemy die for his."
#2AbominuZPosted 7/18/2012 12:21:33 PM
Did you try the basic stuff ?

Run as admin
Keep the installer and shortcut in the same map
Download client with IE ?
Disable anti virus
Try saving client in a different path
#3dejavu1982Posted 7/18/2012 1:15:17 PM
Ive also got win.7, and i havent had to change anything, i use firefox instead if IE though, not sure if that means anything.
#4Rethalwolf(Topic Creator)Posted 7/18/2012 2:11:04 PM
Yeah I've tried all of that, and the downloader itself usually downloads fine but when i try to use it it crashes immediately.
---
"The point of war is not to die for your country. It's to make the enemy die for his."
#5Zelda_wood_elfPosted 7/18/2012 3:06:54 PM(edited)
Rethalwolf posted...
Yeah I've tried all of that, and the downloader itself usually downloads fine but when i try to use it it crashes immediately.


I believe I ran into this issue but in my case it was my fault because I failed to follow instructions by not making sure the files where all in the same folder.

Iinstead of creating a shortcut to run guild wars 2 I dragged and dropped the startup icon on my desktop home screen.

After awhile I finally put it in the folder and created a shortcut for it to my desktop and then I had no more problems! ^_^

Well aside from avg antivirus not allowing me to run guild wars 2 but after a few helpful recommendations I uninstall that ish and got Microsoft security essentials and maleware bytes.

Now I can run guild wars 2 without having to turn off my antivirus as was the case when I was using AVG.
#6Rethalwolf(Topic Creator)Posted 7/18/2012 9:54:26 PM
I don't think that's the same problem.
Here's what happens for me.
1) Go to https://account.guildwars2.com/download
2) Press download
3) (In IE) Press Save
4) Press Run
5) Download seems to start up until ~10136 KB
6) Get error message C:\Users\Brent\AppData\Local\Temp\MSIMG32.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.

Thing is, last week when I tried downloading it on Chrome, it worked and I got all the way to the menu. Then after I heard there were updates, I tried running it again (it never gave me a shortcut or anything to open it so I had to run the downloaded installer to get to the title screen) and it crashed with that same window for the first time since the download was successful.
Since then I haven't been able to redownload it from any client, open it, etc. I've deleted and tried to redownload everything. I've tried every solution I can think of.
Thing is, I had the same problem with Skype. I couldn't download an update. But when I uninstalled and reinstalled it, the update was included and it worked.

So obviously it sounds like a computer problem but I have no idea how to find or fix it. Any ideas?
---
"The point of war is not to die for your country. It's to make the enemy die for his."
#7Rethalwolf(Topic Creator)Posted 7/18/2012 11:28:11 PM
I'm just gonna bump this right quick cuz I really, really want to play the beta.
---
"The point of war is not to die for your country. It's to make the enemy die for his."
#8Grey_AsakuraPosted 7/19/2012 12:43:19 AM
system restore?
---
http://i.imgur.com/ZuXHL.jpg
~Delicious Erza tears....~
#9Xeeh_BitzPosted 7/19/2012 1:42:48 AM
[This message was deleted at the request of the original poster]
#10Xeeh_BitzPosted 7/19/2012 1:44:09 AM
Also delete the twp tmp or whatever the hell it is file

along with the .dat file.. start over in the directory where the original exe is placed
---
Bacon