ATTN: People with authentication issues

#1plokis246Posted 9/1/2012 3:49:25 PM
It might only be me, but I was NOT receiving my email on FIREFOX. I switched over to GOOGLE CHROME and the email was received right away.
---
While they sleep soundly at home, our families
DIE IN WARS DESIGNED TO FAIL
#2SW_FFXIfanPosted 9/1/2012 3:50:19 PM
I'm using google chrome and it isn't working :/
---
LoL IGN: Butch Magnus
#3plokis246(Topic Creator)Posted 9/1/2012 3:50:52 PM
Try switching to another... I don't know why this would have worked for me.
---
While they sleep soundly at home, our families
DIE IN WARS DESIGNED TO FAIL
#4SW_FFXIfanPosted 9/1/2012 3:57:53 PM
Well really the browser would not be the issue at all. It would be them simply sending out the emails.
---
LoL IGN: Butch Magnus
#5EternalFlame66Posted 9/1/2012 3:58:57 PM
SW_FFXIfan posted...
I'm using google chrome and it isn't working :/

---
Such is your fate.
#6The DevourerPosted 9/1/2012 4:01:03 PM
Mine's not working at all. And this is why I hate email authentication ****. The same thing happens when I have to reset my itunes password.
---
FX6100, HD7970, 8G DDR3 1600, 750G/400/1T SATA2/3, 700W, Logitech G5/G510, Win7
XPS16 - i7 720QM, 6G DDR3@1333, 500G SATA, HD4670 1G, Win7
#7Xero KaiserPosted 9/1/2012 4:29:01 PM(edited)
SW_FFXIfan posted...
Well really the browser would not be the issue at all. It would be them simply sending out the emails.


Actually he's right. I went to guildwars2.com (on chrome, since the site wouldn't work with firefox) and authenticated my account from there and the email went out. After following the link and clicking "allow access" and "remember this network" I was able to log into the actual game..