Resolution Fix

#21TaelithPosted 6/16/2009 4:09:21 PM
"Never said I disliked just saying there is a fix too it already, and its called the new generation."

So I can either edit a simple file quickly and easily with the info he used, or go out and spend another $500 or so to upgrade equipment? Tough choice. Thanks, but I'll take his fix over yours.
#22xerotoninePosted 6/16/2009 4:17:15 PM
Well what are you rocking taelith?

If you're using some weak sauce gpu like an 8600GT or some laptop pos you might as well shell out. And check your prices again.. Last I checked 9800GT's could be had for $90 and HD4850's could be had for $115.
---
Currently Playing: GTA IV (PC) // Prototype (PC) // Saints Row 2 (PC) // Mirrors Edge (PC) // Castlevania SOTN (PSP)
#23LamoidzyPosted 6/19/2009 3:49:24 PM

When I do this to get it running at 1680x1050 everything looks good but I get a one inch black bar on the left side of my screen.

#24LamoidzyPosted 6/19/2009 3:51:07 PM
and yes I am using a 1680 x 1050 native resolution monitor.
#25sophophilicPosted 6/19/2009 5:22:23 PM
I have a current-gen video card with 512MB of memory and the usual high resolutions are locked to me, leaving me with the fecal ones. Considering that I play on a 1080p monitor, I'd rather be able to use something higher than what the game allows me.

I'll try this out later, thank you for the fix. I hope it works.
#26CYBORG112Posted 6/19/2009 5:41:55 PM
the running in windowed mode and changing the resolution to desired one , then quiting the game and running it maximized worked for me.

only problem is my mouse cursor wont go away.

i have an Ati Radeon HD4870x2 1 gb video card
and i can only select up to 1280x800 resolution
which is a bit strange.

i hope they fix it.
---
Cyborg112 The Legendary Hero Of Robots..
Not Changing My Sig Till My Batterie Dies...
#27rrcp1usPosted 6/20/2009 6:59:52 AM

Sosseres posted...
First go to games shortcut then open its properties.

Then add the target line "windowed".
(no - or whatsoever,just space and windowed.)
Like this : "C:Program FilesActivisionPrototypeprototypef.exe" windowed

Start the game windowed.

Go to your game's video settings and select the resolution or aa
level you want.

Exit the game.

Right click the shortcut and select properties again.

See,there is a value called run.Make it "Maximized" and click Apply.


Here you go,have fun ^^


Worked like a charm, thanks!

#28pusse84Posted 6/21/2009 5:01:57 AM

MASTERBLARG posted...
Ok, I figured out a way to fix the resolution, thanks to some old half life hacking. This is very similar. All the config files are stored in a .dll. Which is pretty annoying, it gets a bit complicated changing the values. So first you'll need a hex editor, any will do, just do a google search for hex editor.

Now, first run the game and change the resolution to 640*480. That's a resolution I'm sure everyone's card has available to them.

Now, exit the game and open the file prototypeenginef.dll with your hex editor.

Search for the hex value 80020000E0010000.

There are two parts of that value you need to edit. 8002 is the horizontal resolution (640) and E001 is your verticle (480).

So all you have to do is change those two values with the one's that you use.

1024x600 - Replace 80 02 with 00 04 and replace E0 01 with 58 02
1280x720 - Replace 80 02 with 00 05 and replace E0 01 with D0 02
1280x800 - Replace 80 02 with 00 05 and replace E0 01 with 20 03
1366x768 - Replace 80 02 with 56 05 and replace E0 01 with 00 03
1440x900 - Replace 80 02 with A0 05 and replace E0 01 with 84 03
1680x1050 - Replace 80 02 with 90 06 and replace E0 01 with 1A 04
1920x1080 - Replace 80 02 with 80 07 and replace E0 01 with 38 04
1920x1200 - Replace 80 02 with 80 07 and replace E0 01 with B0 04

If you want an obscure resolution or something higher than that you'll just have to do some research on what the hex value would be, shouldn't be too difficult.

Then just save the file and run the game, you should now be running in your custom resolution automatically. However, if you ever edit the resolution settings this will reset and you'll have to do it all over again.

I know it's a bit complicated, but if you want an odd resolution, this is your only hope, they probably aren't going to "fix" this in the patch.


Hi, I cannot find the given hex value with a search in the hex editor, even though I followed the instructions. I'm not sure if the other video settings (vsync, shadows, etc.) can affect the values that I'm supposed to edit..?

Anyway, Masterblarg, or anyone that has been able to "fix" their resolution with hex editing, could you please give me the offset of the hex values for the resolution in the prototypeenginef.dll file? It would help me to locate the values I would need to edit in order to be able to set the resolution to 1280x1024.

Thanks!

#29pusse84Posted 6/21/2009 5:34:47 AM

Ok when I changed both shadows and texture quality to "low", I found the hex value. However, now that I change it, it always resets back to 800x600 when I start the game (even if the dll file is set to read only). Any ideas?

#30ShadowdudeevilPosted 6/21/2009 8:42:31 AM
Thanks for this information, I'm going to go try it right now and see if it works. Considering I have an 8800GTS 320MB, putting down almost $300 for a graphics card when it came out and then having to run ANY game at 1024x768 on my 1680x1050 monitor is annoying, to say the least. This game is more CPU-intensive than GPU-intensive, and it's stupid to restrict things based on the GPU. I can play Crysis at medium settings at 1680x1050, so I'm sure my graphics card can handle this game on high settings at the same resolution.
---
Friend codes are Nintendo's way of saying, "We don't want people to have fun with our online games!"-very_sexy