Direct3d error - solution (for some)

#1Black_GregPosted 1/5/2009 5:25:56 PM

I originally posted this on the CnC 3 forum. Just thought I'd post it here incase people are having the same problem with Kane's Wrath.

Regarding the problem that E.A has refused to address with people, whereby in the middle of a battle you are returned to windows and informed that you have run 'out of memory', also the cnc3.dat error which seems to be related.. (by the way, an indicator that you're having this problem seems to be weird gdi red tank tracks. For ages, I thought that was normal but they stopped turning red after I solved this crashing problem)

Basically, like most people I tried a thousand and one ways of fixing this.. eventually I stumbled across these guys talking about AGP/Direct3d problems for ATI graphics card users. My RadeonX1300 is one of the versions that suffers with this compatability issue. Downloading these drivers (ATI Catalyst 8.12 XP 32-bit) finally solved the problem:

http://downloads.guru3d.com/Videocards---ATI-Catalyst-XP-32-bit_c18.html

Of course, I don't know how this works for people with other graphics cards or Vista so if that applies to you, this link may at least provide you with some idea of wtf is going on: http://www.dslreports.com/forum/r19779875-For-those-ATI-users-with-AGP-Direct-3D-problems