DirectX Error Code 3 Soluion

#1FrunDeatt66Posted 12/26/2012 2:59:07 PM
Hello everyone. I'm writing this in hopes that it will help someone out. If you are playing Just Cause 2 and are getting a DirectX Error Code 3, then here's the fix for you.

Right click on the steam icon of JC2 and go to properties>Set Launch Settings

Type the following:

/dxadapter=0

And it should work. The problem occurs when your system has two graphics cards installed and JC2 gets confused.

I hope this helps!
---
"After I die, you can eat my brain. It will give you power." -Duke Phillips
psnprofiles.com/FrunDeatt66
#2Orik306Posted 1/6/2013 10:22:40 PM
Sir, your wish has come true. Thankyou very much /bow
#3FrunDeatt66(Topic Creator)Posted 1/16/2013 10:46:06 AM
There's some problems with this "solution" I posted.

Going into the launch settings and typing "/dxadapter=0" will open JC2. However, it uses the intel integrated graphics card and not the nvidia one (in my case). So this really isn't a solution.

Another thing you could do is go into the bios. Hit F2 during start up (I think it's F2, for my laptop). Then change the graphics card options from "switchable graphics" to "UMA graphics" (the only two options I have). This will get the game to play, but not well, but better than the first solution.
---
"After I die, you can eat my brain. It will give you power." -Duke Phillips
psnprofiles.com/FrunDeatt66
#4TheCadaverPosted 2/2/2013 2:52:07 AM
i think were in the same boat

i have a 650m and ive been racking my brain for fixes

i have no idea why just cause 2 is such a nuisance to run

Error codes >wrong graphics card

i thought the dxadapter is supposed to make it use the second graphics card but the performance makes more sense
i can hit like 60 fps in borderlands 2 on near max settings and other games but this struggles to get 30 on the lowest settings
man they really should release a fix this is like the only game ive heard of to have this problem
---
"Express your talents in art and music"
#5billyevansPosted 2/2/2013 3:20:47 PM
Here's an ACTUAL solution for this error.
http://steamcommunity.com/app/8190/discussions/0/846940249220324722/

This solution is for laptops, considering the majority of users getting this error are using laptops as there is a conflict with Just Cause 2 and Nvidia Optimus technology.

PART 1: This is to get Just Cause 2 to launch

1. Right click Just Cause 2 in your Steam Library and select PROPERTIES.
2. Select LAUNCH OPTIONS, and type in "/dxadapter=0" without quotes. (http://i.imgur.com/YaNZ8.png)

PART 2: This is to get your graphics card to render the game (Steps 4-7: http://i.imgur.com/VAkZW.png)

1. Download Nvidia Inspector from: http://tinylink.net/nvidiainspector
2. Open Nvidia Inspector
3. Click the button to the right of DRIVER VERSION.
4. From the PROFILE menu, select JUST CAUSE 2.
5. Scroll down the window until you find: Shim Rendering Mode Options per application for Optimus.
6. Click the text to the right, scroll to the top of the dropdown, and select SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE
7. Click APPLY CHANGES in the top right-hand corner.
8. Run your game
#6FrunDeatt66(Topic Creator)Posted 2/3/2013 11:05:38 AM(edited)
billyevans posted...
Here's an ACTUAL solution for this error.
http://steamcommunity.com/app/8190/discussions/0/846940249220324722/

This solution is for laptops, considering the majority of users getting this error are using laptops as there is a conflict with Just Cause 2 and Nvidia Optimus technology.

PART 1: This is to get Just Cause 2 to launch

1. Right click Just Cause 2 in your Steam Library and select PROPERTIES.
2. Select LAUNCH OPTIONS, and type in "/dxadapter=0" without quotes. (http://i.imgur.com/YaNZ8.png)

PART 2: This is to get your graphics card to render the game (Steps 4-7: http://i.imgur.com/VAkZW.png)

1. Download Nvidia Inspector from: http://tinylink.net/nvidiainspector
2. Open Nvidia Inspector
3. Click the button to the right of DRIVER VERSION.
4. From the PROFILE menu, select JUST CAUSE 2.
5. Scroll down the window until you find: Shim Rendering Mode Options per application for Optimus.
6. Click the text to the right, scroll to the top of the dropdown, and select SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE
7. Click APPLY CHANGES in the top right-hand corner.
8. Run your game


This is great! I'm glad this error got solved. This worked for me and now I'm running JC2 perfectly. Thanks for the help and everyone that posted on this thread!

EDIT: I just wish I spelled "solution" right in the title... all well.
---
"After I die, you can eat my brain. It will give you power." -Duke Phillips
psnprofiles.com/FrunDeatt66