VERY IMPORTANT - Turn off NVIDIA PhysX GPU acceleration for Crysis

  • Topic Archived
  1. Boards
  2. Crysis Warhead
  3. VERY IMPORTANT - Turn off NVIDIA PhysX GPU acceleration for Crysis
6 years ago#1

Crysis and Crysis Warhead DO NOT support NVIDIA PhysX GPU acceleration, so turn it off via NVIDIA control panel if you've got it. I have a GTX 295 card on Win7 64-bit (DX 11), and Crysis had degraded graphics with PhysX enabled. Transparency is all messed up (e.g. burning embers and other things like the alien in the transport crate you are chasing (Warhead)) and also there is strange flickering and degraded shadows if PhysX is enabled. Turn off PhysX for Crysis!!!!!! This had me quite frustrated for a few days until I figured it out.

6 years ago#2

My problems started after installing the latest NVIDIA driver, version 195.62. Rolling back to 191.07 fixes all problems. I searched the web and othesr are having problems with the latest driver as well. With 195.62, Crysis/Warhead have major problems. So, the problem may not be related to PhysX, but as Crysis doesn't support its use, I'd still turn it off.

6 years ago#3
thankyou for this, i just got this installed with allt he mods again but havent ran it yet, and i have the latest drivers installed. thankyou for the heads up
6 years ago#4
I will keep that in mind, but so far I have not noticed any difference.
  1. Boards
  2. Crysis Warhead
  3. VERY IMPORTANT - Turn off NVIDIA PhysX GPU acceleration for Crysis

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived