Screen tearing/black splotches

#1T6D16C84Posted 4/26/2012 11:50:05 AM
Just rebuilt a new setup. Installed TOR, was working fine then I alt tabbed out and back in, afterwards I started getting horrible screen tearing and black flashing splotches all over. FPS is solid, but the animations are so herky jerky and unstable. Tried to quit and relog, no change, restarted computer no change, repaired files no change....any have this issue?

My setup

Mobo Asus M5A97
CPU amd fx 4100 (Turbo at 3.8)
Ram gskill DDR3 1600 16g
Psu corsair 750hx
Video sapphire HD6870

All drivers are current and my BIOS is current as well
---
-Remember, the enemy's gate is down- I guarantee most of you dont know what im talking about!
#2Visani_ChantePosted 4/26/2012 11:53:52 AM
Isn't there an option that deals with this? Like Vertical Sync or something?
#3ultimateballoonPosted 4/26/2012 11:54:43 AM
Toggle v-sync to help with the tearing.
#4T6D16C84(Topic Creator)Posted 4/26/2012 11:55:16 AM
Have switched it off and on, no change
---
-Remember, the enemy's gate is down- I guarantee most of you dont know what im talking about!
#5ultimateballoonPosted 4/26/2012 11:58:56 AM
T6D16C84 posted...
Have switched it off and on, no change

Ask on the customer support of the official forums. You may have to re-install the client though.
#6siglumdiobolikPosted 4/26/2012 12:38:16 PM
the asus mobo's have been stated to having problems with the fx procs. so i would try turning the boost off of the proc then check your card settings. judging by your description and the fact that swtor is processor heavy you might be demanding to much from it with the asus instability. other than that i dont know what to tell you. maybe check your internal temps and re-evaluate your ventalation