Can't connect to IWNet?

#1shpo2Posted 11/15/2009 12:25:15 PM
Every time i try and connect in multi player and spec. ops it just sits there at connecting to iwnet... I have forwarded all the needed ports and I checked to see if they were open through a program. Any ideas on why I can't connect?
#2cloakedboltzPosted 11/15/2009 12:26:14 PM
Try to check with your ISP to see if they blocked those ports.
#3bob666satanPosted 11/15/2009 7:53:26 PM

i've been getting the same thing all weekend.. here's my deal (copied from another forum)

Here's my system:

Windows Vista Home Premium 32bit
Intel D820 on a D965RY w/ 3gb RAM and lots of drive space
BFG GTX275OC w/ latest Nvidea drivers (not beta)

Connected w/ a static IP to a Linksys WRT54G that is connect (w/ static IP) to the ISP's dsl modem.

Here's what i've done so far to try to resolve this:

- Uninstalled/reinstalled Steam & MW2

- Connected my PC directly to the internet

- Verified (with PFPortChecker) that I have ports 1500, 3005, 3101, 28960 & 27000-27050 open for Steam and MW2.

- I've tried with the windows firewall disabled/enabled & uninstalled my AV software

- Tried creating port rules 2 ways; 1 in the main windows firewall (Allow program or port) & 2 in the Administrative Tools>Firewall with Advanced Settings (created incoming and outgoing rules)

- Rebooted/Reset PC, Router, Modem, etc... countless times at this point.

- Tried "Run As" Administrator command opening Steam and MW2.

**** edit *****
- Tried installing on laptop (XP Pro, faster specs than desktop except graphics is 9800mGT)

same result - hangs at "Please wait - Connecting to IWNet..."

****edit****
Back on desktop PC - checked router logs while trying to connect.

Verified it is attempting to contact 72.165.61.187 which looks like it works.

Also trying to hit 63.241.188.230 which I can't ping and tracert dies enroute.

...Boy, I sure wish there were dedicated servers.