Game is unplayable since the patch, any help?

#1LithspPosted 3/7/2013 4:46:15 PM
I'm getting ridiculous FPS, crazy amounts of lag, not sure WTF is going on.

Honestly, it's just insane. Nothing on my PC has changed from before the patch so I don't know wth is up.

Anyone else experiencing crazy lag/FPS problems?

I've never had lag or FPS problems in my life, always kept my PC's up to date etc etc.. shouldn't be having any problems, especially with this game.

All I can do is steer clear of ranked (dropped a few divisions because I keep trolling myself and my team, thinking maybe the lag will be gone next game).
---
[]Signature[]
#2Arken101Posted 3/7/2013 4:47:09 PM
Open up league, when it's at the launcher click the gears in the corner and click repair.
---
[http://animebot.everyboty.net/pix/866.jpg] [http://i.imgur.com/xx0hSNV.png]
PSN/360: Maximal769 Garen's mai waifu
#3profDEADPOOLPosted 3/7/2013 5:47:55 PM
Yea I have had the FPS problem but not the lag problem.

Repair didn't do anything for me.
---
Official Mienshao of the pokemon B/W and BW2 clan
Comic pull list: UXF, WatX, C&XF, Gambit, Young Avengers, Hawkguy, GA, I, Vampire, JLD and Constantine
#4Arken101Posted 3/7/2013 5:52:06 PM
Skarner breaks my game everytime I play him, messes up all my textures and stuff.
---
[http://animebot.everyboty.net/pix/866.jpg] [http://i.imgur.com/xx0hSNV.png]
PSN/360: Maximal769 Garen's mai waifu
#5Lithsp(Topic Creator)Posted 3/7/2013 5:54:05 PM
profDEADPOOL posted...
Yea I have had the FPS problem but not the lag problem.

Repair didn't do anything for me.


I repaired, nothing. It's only since this patch too.

It's 100% unplayable for me at the moment. Dropped a couple of divisions, no good.

I'm thinking of just not playing until it's addressed or wait until the next patch and see how it is.

Definitely can not play at the moment though, the FPS is just ridiculous.. like it'll just skip from me running from base to my lane, and then the next frame I see is me dead, 5 man ganked.
With nothing in between. Just one from I'm not in danger, next instant, dead. Ridiculous.
..and no, Fizz hasn't been appearing and 100-0ing me in 0.00 seconds lately either.

It's pissing me off TBQH.
---
[]Signature[]
#6MaurithPosted 3/7/2013 5:54:05 PM
I keep getting freezes during the loading screen, and sometimes the game freezes within the first 5 seconds or so of the game starting. Seems to be happening about 1/3rd of the time :/
---
Official Floatzel of the Pokemon XY boards
http://i78.photobucket.com/albums/j90/kouta-k6/favouritepokemon_zps877a78e5.png
#7edubsPosted 3/7/2013 5:57:09 PM
Lithsp posted...
profDEADPOOL posted...
Yea I have had the FPS problem but not the lag problem.

Repair didn't do anything for me.


I repaired, nothing. It's only since this patch too.

It's 100% unplayable for me at the moment. Dropped a couple of divisions, no good.

I'm thinking of just not playing until it's addressed or wait until the next patch and see how it is.

Definitely can not play at the moment though, the FPS is just ridiculous.. like it'll just skip from me running from base to my lane, and then the next frame I see is me dead, 5 man ganked.
With nothing in between. Just one from I'm not in danger, next instant, dead. Ridiculous.
..and no, Fizz hasn't been appearing and 100-0ing me in 0.00 seconds lately either.

It's pissing me off TBQH.


Did you try uninstalling the re-installing? Not ideal but it may fix your problem
---
Greatest system of all time is the N64. OOT, SM64, Paper Mario DK64 and Ogre Battle
not changing my sig until the Pirates have a winning season started 3/31/08
#8Lithsp(Topic Creator)Posted 3/7/2013 5:57:43 PM
edubs posted...
Lithsp posted...
profDEADPOOL posted...
Yea I have had the FPS problem but not the lag problem.

Repair didn't do anything for me.


I repaired, nothing. It's only since this patch too.

It's 100% unplayable for me at the moment. Dropped a couple of divisions, no good.

I'm thinking of just not playing until it's addressed or wait until the next patch and see how it is.

Definitely can not play at the moment though, the FPS is just ridiculous.. like it'll just skip from me running from base to my lane, and then the next frame I see is me dead, 5 man ganked.
With nothing in between. Just one from I'm not in danger, next instant, dead. Ridiculous.
..and no, Fizz hasn't been appearing and 100-0ing me in 0.00 seconds lately either.

It's pissing me off TBQH.


Did you try uninstalling the re-installing? Not ideal but it may fix your problem


Yeah, this was the first thing I did. Wasted my time and didn't work. LOL.
---
[]Signature[]
#9Labyrinth TankPosted 3/7/2013 6:06:58 PM
I don't know if this is the same problem you're having, but I was getting some pretty bad lag when I put Windows 8 on my computer. What I had to do was run it as an administrator and put it in Windows 7 compatibility mode. The lag that used to plague me every single game was completely gone after that.
---
"Did you avenge me? Awesome!" - Kargon
#10Lithsp(Topic Creator)Posted 3/7/2013 6:27:13 PM
Labyrinth Tank posted...
I don't know if this is the same problem you're having, but I was getting some pretty bad lag when I put Windows 8 on my computer. What I had to do was run it as an administrator and put it in Windows 7 compatibility mode. The lag that used to plague me every single game was completely gone after that.


I've always had windows 8 on this PC. It's new. Might give this a look into though. How do I do this?
---
[]Signature[]