Game is unplayable since the patch, any help?

#11ssupermario92Posted 3/7/2013 6:38:50 PM
Lithsp posted...
Labyrinth Tank posted...
I don't know if this is the same problem you're having, but I was getting some pretty bad lag when I put Windows 8 on my computer. What I had to do was run it as an administrator and put it in Windows 7 compatibility mode. The lag that used to plague me every single game was completely gone after that.


I've always had windows 8 on this PC


http://www.dota2wiki.com/images/c/c2/Tusk_failure_03.mp3
---
Super Mario Bros. 3 is better then Super Mario World
People who agree: 47 PM if you think so as well Latest person who agrees: Athiniel
#12MwarriorHieiPosted 3/7/2013 6:45:16 PM
ive been having lag problems as well. its getting ultra annoying.
---
http://i.imgur.com/TQEciMP.jpg
#13Labyrinth TankPosted 3/7/2013 6:49:02 PM
Lithsp posted...
Labyrinth Tank posted...
I don't know if this is the same problem you're having, but I was getting some pretty bad lag when I put Windows 8 on my computer. What I had to do was run it as an administrator and put it in Windows 7 compatibility mode. The lag that used to plague me every single game was completely gone after that.


I've always had windows 8 on this PC. It's new. Might give this a look into though. How do I do this?


Right-click the shortcut for the game and click on Properties. In the window that pops up, click the Compatibility tab, check "Run this in compatibility mode" and select Windows 7 in the drop down menu. Then check the box at the bottom for running it as admin.
---
"Did you avenge me? Awesome!" - Kargon
#14supershadonicPosted 3/9/2013 3:40:59 AM
Don't worry TC. they are probably looking into it. Its a known problem. There are many topics of it here as well as League boards. I'm having this problem too. Not your PC problem. Its on Riot's end.
#15JJroootPosted 3/9/2013 8:40:46 AM(edited)
Try this Start LOL and log in to the main menu.

CTRL + ALT +DELETE

Start Task Manager> Processes

Find LOLClient.exe

Right Click on it and select "Set Affinity"

Un check every cpu EXCEPT cpu0

Doing this makes my game run at 60 fps 95% of the time.

(Sometimes it drops but only on rare occurrences and for only a split second)

And yes i was having fps issues since the patch as well...

(Fps dropping to mid 30's and sometimes 20)
---
If alcohol is a crutch, Jack Daniels is a wheelchair
Xbox Live GT: Saynt614
#16WrydrunePosted 3/9/2013 10:52:05 AM
I thin I was having the same issue where my fps would randomly drop to like ~5. I disabled hud animations and now I run at 40+.
---
Capcom on racism:
We don't care what race our fans are, because we don't care about our fans.