Co-Op is free? No Live needed?

#1konkorPosted 12/11/2011 6:00:15 AM
Before you say "It is system link" I will explain, I just bought a new X360 and got a few games. I never bought Xbox Live Gold. I just entered the redeem code for the Co-Op so I didn't lose it and it said to play online now! So I thought it won't work but I can wish. It actually loads up, asks to choose a save and then finds a player but it says "Player is busy they asked you to wait" So I was wondering if anyone knows if this is free? If not does anyone want to add me so we can try?

My Gamertag is "Police Official" without the quotes.
#2BassGsSpDeluxePosted 12/11/2011 7:22:05 AM
No, you need Gold to play non-system link co-op.

It's always been this way.
---
Now Playing - Skyrim /// Waiting For - Mass Effect 3 (Now with 4p co-op <win!>)
#3Amazing_BlazePosted 12/11/2011 7:30:03 AM
Dont you get like a free month for live?
---
---Pokemon white FC
4427 3594 7406
#4PapaRosario23Posted 12/11/2011 7:38:59 AM
konkor posted...
My Gamertag is "Police Official" without the quotes.

Nice try, Cyrus.
---
Your mother is so fat that the recursive function computing her mass causes a stack overflow.
#5krammaiiPosted 12/11/2011 10:08:01 AM
It is a free Gold weekend.
---
Xbox - krammaii
PSN - marktron
#6konkor(Topic Creator)Posted 12/11/2011 10:11:29 AM
No I don't have a free month because my console was second hand. I just saw on the dashboard though that this weekend is Xbox Live Gold free. Also my Gamertag is actually "Police Official", I couldn't think up a better Gamertag and almost everything I tried was taken. Since my previous one "Konkor4" was reset because my idiotic friend tried to hack it i had to make another.
#7nnytherkillerPosted 12/11/2011 2:26:03 PM
Actually I was playing this in co-op the other day, during the week it was not during the free gold weekend, and my time ran out yet i was still able to continue playing co-op with my friend. Granted I was not able to stay in the party so we had to use game chat.
---
GT. nnythekiller
Stoic wanderer
#8konkor(Topic Creator)Posted 12/11/2011 3:56:49 PM
I was able to use the upload/download feature for clothing also, although I couldn't do that for screenshots. Maybe a bug?