Map Locations not Registering Glitch. Any Input Appreciated

#1Sonorous_Jon1S8Posted 9/19/2010 9:46:32 AM
I have 90% completion thus far and have beaten the game[did the mission, watched the credits roll]

I have purchased every map but the great plains map(in the Blackwater General Store),because it says not available. Never bought it before and only 12/17 West Elizabeth locations. The remaining 5 West Elizabeth locations i am missing i have been to multiple times, thus they arent registering.

The only glitchy thing that has to do with this i can think of is sometime after finishing Mexico, i was given the option at some general stores to repurchase area maps that i know i previously bought... So i re-bought them and used them for the hell of it(this might be what caused the glitch...). Since then ive gone to every general store to look for maps i havent re-bought and used so i can maybe 'reset' the glitch... the only map ive found is Cholla Springs.

Saving then loading the game has done nothing. Testing using Mason bridge since it should be literally impossible to miss if you ride directly over the bridge. It hasnt worked but the area name at the top of the screen does show like its supposed to in the places im 'missing'...

In Game Stats>General

Areas 93/94
New Austin 47/45 (i have no idea where the 2 extra come from)
Nuevo Paradiso 34/32 (i have no idea where the 2 extra come from)
West Elizabeth 12/17

According the the Social Club 100% Checklist, areas im missing

Mason Bridge
Montana Ford
Tanner's Reach
Wreck of the Serendipity
Broken Tree

ive gone to them all multiple times and some were mission locations that i couldnt possibly have not gone to.

It gets weirder... My last option was to go out in front of Blackwater General Store and use that Cholla Springs map in the hopes ill 'fix the glitch so i can either buy the last map or get the locations myself... So i used it and I just got the "On the Trail of de Vaca(all locations)" trophy right after and now...

Areas 94/94
New Austin 48/45 wtf
Nuevo Paradiso 34/32 same
West Elizabeth 12/17 still the same on Social club too.

I have no idea if its altered my completion percentage, after a save/load i still cant buy the Great Plains maps or 'discover' the locations when i go there.

Any suggestions that dont involve restarting my save are really appreciated. I have no idea if this is patch related, it might have started right before or after it.

If you ever, EVER get the option to buy maps youve already used do not buy them. And if you do buy them, DONT use the damn thing. And if you decide to use them you better have gotten your mother ****ing 100% percent already.

I gotta say, this really sucks out my motivation to grind the last 10% for 100% when i probably wont be able to obtain it and dont much feel like trying out online now either. Kind of like someone dropping a dookie on my ice cream sundae when im eating it. I thought only bethesda made good games this glitchy. >_>

/thetearsbutnotthepain
#2Sonorous_Jon1S8(Topic Creator)Posted 9/19/2010 9:50:13 AM
Also, i dont quite remember but dont areas that you havent discovered have no name on the map. For instance if ive never been to Rattlesnake hollow, wouldnt if i looked directly at the correct area on my pause map there would be no 'heading' saying Rattlesnake Hollow...

If thats the case, all of the locations im missing are written on my pause my, if its not the case forget this post.
#3banzaiheilPosted 9/19/2010 10:17:38 AM
I wish I had an answer for you, but unfortunately this is the first I've heard of it. The pessimist in me would assume that since we just had a new patch, it may be the problem. The first thing I would try, if it were me, would be to delete the game data and try again playing with the unpatched version, hoping for the best. But, more than likely the save may be permanently screwed up. Still worth a shot though.
---
"I see," said the blind man, as he picked up his hammer and saw.
PSN: BanzaiHeil
#4Sonorous_Jon1S8(Topic Creator)Posted 9/19/2010 10:48:23 AM
Deleting Game Options was worth trying but unfortunately it didnt help. Seeing other people who have restarted the game at >90% makes me feel more willing to give it another shot but after looking at the rockstar red dead forums im slightly worried that ill encounter some other glitch(god knows this one wont happen to me again). I thinking just rushing the story would be the best way to avoid other glitches.
#5banzaiheilPosted 9/19/2010 11:00:28 AM
I have to ask because of the words that you used, did you delete game options or game data?
---
"I see," said the blind man, as he picked up his hammer and saw.
PSN: BanzaiHeil
#6Sonorous_Jon1S8(Topic Creator)Posted 9/19/2010 11:08:01 AM
[This message was deleted at the request of the original poster]
#7Sonorous_Jon1S8(Topic Creator)Posted 9/19/2010 11:12:01 AM
[This message was deleted at the request of the original poster]
#8Sonorous_Jon1S8(Topic Creator)Posted 9/19/2010 11:15:46 AM
I Deleted

Saved Data Utility(PS3)>Red Dead Redemption>Game Options


The Game Data(install/patch data) i left in tact

sorry for the triple post.
#9banzaiheilPosted 9/19/2010 11:16:02 AM
Yeah, that install and patch data is what I meant for you to delete and play without reinstalling the patch data.
---
"I see," said the blind man, as he picked up his hammer and saw.
PSN: BanzaiHeil
#10Sonorous_Jon1S8(Topic Creator)Posted 9/19/2010 11:21:54 AM
Should have deleted Game Data>Red Dead Redemption instead...

I just re read your post and saw you said game data. I think i saw you recommend someone with a freezing problem to delete 'game options' and my brain just fillied in the blanks..

Man i am off my game today, i guess ill go delete the correct data now and see if it makes a difference. >_>