For the Republic - Part 2: Gamebreaking glitch?

#1SaienuPosted 11/3/2010 2:41:23 PM
I'm on part 2 where you have to protect the president, Moore directs me to Grant, however, when I get to Grant, dialogue won't active when I speak to him, he just stands there, he's not even inside the building.

Prior to this, I also complete the protect the President quest for Mr. House, has this broken my quest? Is there something I can enter into the console to perhaps refresh Grant?
#2VortaVersePosted 11/3/2010 2:48:03 PM
NPC reset example (in order)Edit href= Edit

prid 3a77 - target Sydney
disable followed by enable - disable and enable, make sure the NPC is active
kill followed by resurrect - kill and resurrect, reset the NPC
moveto player - move NPC to player (or player.moveto 3a77 to move the player to Sydney.)
#3Saienu(Topic Creator)Posted 11/3/2010 2:48:50 PM
Nevermind, just found this on the New Vegas wiki:

"Similarly, completing the You'll Know It When It Happens quest for Mr. House will result in a bug where you can't talk to Grant to start the quest and you can't tell the Colonel that the President is safe."

This is ridiculously frustrating, I keep about 12 save files now, but my last 5-6 saves are still after that quest because I explore, mess around, etc, a lot in between each quest. I'm done playing this game if this means I have to go back 8+ hours just to get back to where I am. And why would they allow for you to do both quests to begin with? Somebody tell me there's something I can do...
#4Saienu(Topic Creator)Posted 11/3/2010 2:49:29 PM
Thanks Vorta, I will try that right now.
#5Saienu(Topic Creator)Posted 11/3/2010 3:01:35 PM
Tried, he still isn't talking.. Not sure what to do now. Anybody have any ideas?
#6MJEmirzianPosted 11/3/2010 3:08:14 PM
You could try resetting Moore.

I'm honestly not sure what the fix for this is, though. You get the same issue if you accept Wild Card: Finishing Touches.

---
http://www.tbstactics.com - Tactical Insights. Tactical turn based tactics and tactical/strategy RPG news/reviews.
#7CarbonightsPosted 11/3/2010 3:09:13 PM
You could just continue the storyline with Yes Man if it comes down to it.
---
PSZ FC - 2965 8766 8608 Nickname - Kyle
#8Saienu(Topic Creator)Posted 11/3/2010 3:31:36 PM
I tried resetting Moore as well, nothing happened. =/
#9MJEmirzianPosted 11/3/2010 3:44:31 PM
Ok, here's what you need to do. Look at the For The Republic quest in the GECK, and find out which objective of the quest it is that you'll be able to progress with. Then you'll want to enter setstage 136166 <Quest Objective number>

That should theoretically place the quest in a status that lets you progress in it.

---
http://www.tbstactics.com - Tactical Insights. Tactical turn based tactics and tactical/strategy RPG news/reviews.
#10MetallermPosted 11/7/2010 3:55:04 PM
I ran into this bug today as well. It took me quite a while to figure out what was going on through trial and error but I've found the fix. Open of the console and try of these commands. After that go talk with Colonel Moore and a new dialogue option should be there.

This will allow you to tell the Colonel the president is safe
"SetObjectiveDisplayed 00136166 65 1"


This SHOULD allow you to tell the Colonel the president is dead.
"SetObjectiveDisplayed 00136166 66 1"