Oh, New Vegas, you hilarious, buggy bastard. (got a Lenovo laptop?)

#1HoonDingPosted 4/6/2013 1:06:11 PM
A cautionary tale, and honestly kinda funny. There's an interesting bug with New Vegas when you try to play it on a Lenovo laptop, like my friend's. He can play almost all of his games on max settings just fine, including Fallout 3, but for some reason, New Vegas would always crash as soon as you started the game. You'd go as far as the title screen (and the first few seconds of the intro movie, or inside Doc Mitchell's house), be able to do anything up to that point, and then it would instantly CTD. No hiccups, no warnings, just an error message and dashed hopes.

This bothered him greatly, for obvious reasons. Reinstalling the game, reinstalling drivers, editing .ini settings, launching in compatibility mode, nothing worked. Then after some Google Fu, we found that this was a problem common to all Lenovo laptops, which is what he has. You know what the culprit is? "Lenovo OneKey Theater", whatever that is. He terminated the processes related to Onekey Theater in his task manager, and suddenly New Vegas works great, everything is gravy. Well, as gravy as New Vegas normally is, at least.

Just felt like sharing that here, just in case anyone else has similar problems.
---
Don't let the dragon drag on!
#2KharilllePosted 4/6/2013 1:43:45 PM
Definitely good to know. I gave a friend my spare copy of FO3 recently. After one weekend of bugs and crashes he uninstalled it and I doubt he'll revisit it.

Personally I play using my game of the year edition. I guess he was too new and didn't patch it up....
#3may_mPosted 4/12/2013 3:50:55 PM
OH MY GOD! I search the heavens for an answer to why my game is crashing on my new Lenovo Y580, fail to find anything, give up and think about what game I'm going to try next, the randomly wander into a topic that blithely gives a possible solution without being asked.

TC, I'm going to hunt you down, kiss you and your friend on the mouth regardless of your gender, then go home and try playing again. Please prepare yourselves by brushing your teeth.

Can you give details/links to where you found out about this and how you solved this, please? THANKYOU!
#4HoonDing(Topic Creator)Posted 4/12/2013 4:49:49 PM
From: may_m | #003
Can you give details/links to where you found out about this and how you solved this, please? THANKYOU!


After we deduced that it was something pertaining to Lenovo laptops, I found a thread on the Steam community forums through some Googling. A few pages in, someone posted the solution. I have it saved from a facebook message, so I'll just quote that, although I unfortunately cannot recall who actually said it.

Registered just to say this:

I'm surprised that apparently the solution still hasn't been found.

I also tried launching New Vegas on a Lenovo laptop and it crashed at the intro movie. I tried disabling the intro in the ini files, it stopped playing but the game still crashed at the loading screen.
I checked the windows event logger, and I noticed that the crash of the fallout executable is connected to a dll that is used by lenovo onekey theater.

SOLUTION: The culprit is Lenovo OneKey Theater. You have to disable it, but it's not enough to do it using the shortcut in start->programs->lenovo->onekey theater.

You need to go to the task manager, find two executables connected to the onekey theater and close them. This fixed the game for me!
(you can sort the processess in the task bar by software manufacturer if you have trouble finding the right ones).

---
https://dl.dropboxusercontent.com/u/11413047/Photos/Hermaeus_Mora.gif
#5gna647Posted 4/13/2013 12:36:47 PM
odd

i have a lenovo laptop and new vegas runs fine.
---
http://i.imgur.com/iMaDK.jpg http://i.imgur.com/e9OCH.jpg
http://i.imgur.com/RnA9A.gif http://i.imgur.com/LvJeR.png