WTH? 30fps with crossfire 5870s?

#19841507Posted 11/9/2010 10:10:07 PM

I've heard of performance issues but is it really this bad?

I'm getting 30fps on Win7 64 bit with an AMD Phenom II@3.6ghz, 4gbs ram and 2 5870s.

Is this normal? Jumps between 30-80, usually around 30 sometimes stutters to 25.

#2comb5Posted 11/9/2010 10:16:34 PM

I get like 10-15 with a Mobility Radeon 4330, so talk about not scaling well. haha. Although that's on all the lowest possible settings for me. From what I've gathered around the web, a patch is majorly needed.

#3Chrypt22Posted 11/9/2010 10:17:17 PM

Game is broken. Honestly anyone that has a computer built in the last 5 years should be able to run this game.... maybe not, I dont know... the Quake 3 engine is a BEAST!!!!

#49841507(Topic Creator)Posted 11/9/2010 10:29:54 PM

Chrypt22 posted...

Game is broken. Honestly anyone that has a computer built in the last 5 years should be able to run this game.... maybe not, I dont know... the Quake 3 engine is a BEAST!!!!



Agreed. I get over 300fps in COD4.

The game looks terribly dated and runs like crap. Disabling crossfire has allowed me to get around 40-100fps on the first mission and it hasn't dropped below 50 on the second mission.


I guess it'll be fine once a crossfire fix is released but it's still garbage. I have no idea how they butchered the engine this badly.

#5Viper3INPosted 11/9/2010 10:33:58 PM
I get above 60fps always on max settings >_>
---
i7 920 @ 3.8Ghz | XFX 5970+5870 | 6GB Corsair XMS3 | EVGA X58 E758-A1 | 80GB Intel X25-M G2 SSD | 2x F3 HD103SJ Raid0 | Corsair HX1000W
360/PS3-DarkChaosViper
#6giocarePosted 11/9/2010 10:35:14 PM
Could it be Steam causing the problem? Let's just say my version of the game doesn't require it, and I'm getting good performance.
#7Black LusterPosted 11/9/2010 10:42:18 PM
Im playing with just one 5870 and it seems to be running 60+ fps.
#8RandomHeroDXPosted 11/9/2010 10:43:33 PM
maybe it has something to do with GPU scaling. I have one 5850 and no problems
---
"The secret to creativity is knowing how to hide your sources." - Albert Einstein
#9jh32uk2Posted 11/10/2010 5:28:45 AM
Game as it is right now may not support Crossfire/SLI properly (not sure on ATI but Nvidia have a mode you can get it to force but not as good as proper support).

Game is also capped to 85FPS in theSP CONFIG, I changed to 125FPS.
#10simonsolidsnakePosted 11/10/2010 6:12:21 AM

6850 here struggling to get 30fps!!

I have been on the offical Black OPs forum and there is one guy on there with a six core processor and SLI 480s and he is only getting 30 -40fps, some people have the problem and some people don't, if you don't have the problem then you are one of the lucky ones.

Treyarch is aware of the problem and they are working on a fix.