My ping randomly goes up high

#1YOUR BASEPosted 11/19/2009 12:07:11 AM
I have been having a problem with this game where my ping will just randomly shoot up and then the game will lag. Sometimes it goes so high that I get a buffer overflow. On bad servers where everyone usually has around 150-200 ping it will sometimes even go over 1000. I was on a server before and my ping was usually 5, but it was still randomly going into the 300s.

I don't think my connection can be the problem because I never had this problem with the demo, L4D, or TF2. Also, my brother was in the same game as me using the same connection and he had no such problems. My specs are:

Core 2 Duo E8400
Radeon HD 3850 256 MB
4GB RAM
Windows 7 64-bit
---
http://miniprofile.xfire.com/vicvipert301.png http://card.mygamercard.net/Teh+Rambozo.png
GAME OVER YEAAAAAAAAAAAAAAAAAAAH! A Leader of "The Shinies"
#2ZijiPosted 11/19/2009 12:11:50 AM
Many of the dedicated servers are probably very far away, causing your ping to go very high.
---
GT: Ziji3909
TheSocialRev.com
#3YOUR BASE(Topic Creator)Posted 11/19/2009 12:15:47 AM
My ping is not constantly high, it is usually the same as everyone else's until it temporarily goes up. Everyone I played the game with lives in the same state as me, but I am the only one having issues.
---
http://miniprofile.xfire.com/vicvipert301.png http://card.mygamercard.net/Teh+Rambozo.png
GAME OVER YEAAAAAAAAAAAAAAAAAAAH! A Leader of "The Shinies"
#4ZijiPosted 11/19/2009 12:17:01 AM
Interesting.

I've had a somewhat similar problem, where if I have 2+ people, I crash. Often.

It disconnects me from the server for no reason whatsoever, and everyone else has no problems.
---
GT: Ziji3909
TheSocialRev.com
#5YOUR BASE(Topic Creator)Posted 11/22/2009 1:25:35 PM
It seems that my ping is usually a bit higher than everyone else on the server and when there are a lot of zombies or action my ping just goes up really high. I just tried a finale in L4D1 and I had no lag or ping issues and my ping was actually lower than everyone else. This issue has to be something with L4D2.
---
http://miniprofile.xfire.com/vicvipert301.png http://card.mygamercard.net/Teh+Rambozo.png
GAME OVER YEAAAAAAAAAAAAAAAAAAAH! A Leader of "The Shinies"
#6albert101Posted 11/22/2009 4:16:12 PM
It happened to me when I was playing L4D 1, but then the problem seem to go away when I play this one. Try closing all the programs through task manager, except the system ones, of course.
---
"I'm da best mayneee i deeed it."
#7ZijiPosted 11/22/2009 4:16:52 PM
Last night, my ping was over 1k, but then next chapter down to 300. Then 1k again. Wut.
---
SteamID: Shorty3909
TheSocialRev.com
#8CaoicePosted 11/22/2009 4:17:42 PM

From: Ziji | #007
Last night, my ping was over 1k, but then next chapter down to 300. Then 1k again. Wut.


While my ping was at 5.

---
Praise the great lord, Liberty Prime, who will *SPOILERS* for your sins.
#9YOUR BASE(Topic Creator)Posted 11/22/2009 10:01:03 PM
bump
---
http://miniprofile.xfire.com/vicvipert301.png http://card.mygamercard.net/Teh+Rambozo.png
GAME OVER YEAAAAAAAAAAAAAAAAAAAH! A Leader of "The Shinies"
#10YOUR BASE(Topic Creator)Posted 11/23/2009 9:38:38 AM
bump
---
http://miniprofile.xfire.com/vicvipert301.png http://card.mygamercard.net/Teh+Rambozo.png
GAME OVER YEAAAAAAAAAAAAAAAAAAAH! A Leader of "The Shinies"